Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by Gustaw 7 years, 11 months ago.

Assigned support staff: Mihai.

Author Posts
February 14, 2014 at 11:24 am #339849

Gustaw

I've updated version of WPML v2.3.4 to v3.1.2 (I use only "sitepress-mulilingual-cms").
When I try to open any page of the translation page is not found.
I tried to disable all other plugins, but it did not help.

Please help me solve the problem!

Example:
hidden link -Works
hidden link -Not working

Info:
-WordPress v3.8.1
-All plugins updated

February 14, 2014 at 11:31 am #339858

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Gustaw,

Sorry to hear about the trouble!

It might be that some elements in the database structure are missing..

# Would you mind providing us with credentials for your website and we have a closer look at the settings? For this purpose you should see a protected webform all they way down here in this thread. (it asks first for "Backup + Legal disclaimer")
Thanks in advance!

February 14, 2014 at 11:40 am #339870

Gustaw

I do not see protected webform

February 14, 2014 at 12:25 pm #339906

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Sorry - do you see it now? Below my reply here?

February 14, 2014 at 12:43 pm #339923

Gustaw

Yes now I see.
I send credentials.

February 14, 2014 at 6:41 pm #340271

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Thanks a lot!

Before I start checking..
In the last 12 hours some critical bugs in our WPML versions were found and also eliminated.
So WPML 3.1.2 is already past again - the current versions are these now: http://wpml.org/my-account/downloads/

# Could you update all your versions again and let me know if it works then?

For updating I recommend our "Installer" plugin*, available here: hidden link

--
* In case you don't see update notifications under "Plugins" please try to clear the Installer Cache under "Settings > Repositories > Inactive Repositories tab"

February 14, 2014 at 8:04 pm #340356

Gustaw

WPML updated to version 3.1.3
Sorry but error still occurs.

February 14, 2014 at 8:08 pm #340365

Gustaw

After finding the cause, please solution, because it is a copy of the original page.

February 17, 2014 at 8:04 am #341085

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Gustaw,

I will pass on your ticket to our developer who coordinates the troubleshooting of new & urgent issues in our development department.
Our developers are working on one more release (~ due next 24 hours )and its good if they get informed about your problem.

Thank you very much for your patience!

February 17, 2014 at 4:58 pm #341755

Mihai

We have released a beta version for WPML 3.1.4. This version includes fixes for everything that was reported for the problematic WPML 3.1 release.

You can get it from your WPML account. Go to Downloads, scroll to the bottom and you will see the beta package. Right now, it's 3.1.4-b1.

This ZIP includes several ZIP files of the individual WPML components. First, unzip it locally, get the parts that you need and upload them.

The safest way to update the plugins is to:
1. Deactivate (don't worry, your content doesn't change)
2. Delete the folders with the older versions
3. Upload the new versions
4. Activate

Please let us know if this version solves the problem. If anything remains, we want to know about it and we will handle it as fast as possible.

We are sorry for the trouble that this had caused you and appreciate your help verifying that the problem is handled.

February 17, 2014 at 6:00 pm #341804

Gustaw

I have upgraded to version 3.1.4-b1, but when I activated I received the following message.

"WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.
Please go to the troubleshooting page and click on Fix languages tables to fix this problem.
This warning will disappear once this issue is issue is fixed."

On this page there is no option "Fix languages tables".
It is the only option "Clear language information.." but then I lose my data translations?!
What should I do?

February 19, 2014 at 10:39 pm #343706

Gustaw

Everything seems to work correctly.
Thank you for your work.