Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.30 hours from now. Thank you for your understanding.

This topic contains 13 replies, has 2 voices.

Last updated by hussainB 2 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
October 28, 2019 at 3:50 pm #4841331

hussainB

I am trying to update the WPML translation management plugin and it gave an error message and could not update. See screenshot.

October 29, 2019 at 2:25 am #4843457

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

Please perform a manual update.
To do a manual update please follow these steps:

1. Backup your database – see for example http://wordpress.org/extend/plugins/wp-db-backup/

2. Deactivate the existing WPML plugin and add-ons.

3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from your "wp-content/plugins" folder NOT the database records.

4. Download the updated plugins from our servers and upload them to the plugin directory.

5. Activate the WPML plugin and add-ons.

Let me know your results, please.

October 29, 2019 at 1:16 pm #4847889

hussainB

Hi,

Thank you. I will try to make it work.
Where do I find the folder?

October 29, 2019 at 5:48 pm #4850803

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

When you use your FTP navigate to your Root Directory/wp-content/plugins and you will find the WPML plugin folders there.

If you run into trouble executing these steps I have enabled the private field reply in order to help you perform them.

October 30, 2019 at 7:01 pm #4858873

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for providing me with a staging site.

When I deactivate "Really Simple SSL" the issue seems to be resolved.

There seems to be a change in the CSS, and it looks like the new CSS is coming from #error_page which is the standard used when a Fatal Error occurs.

I currently don't have access to your site's FTP, if possible please try the following and update me.

You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Also enable

define('WP_DEBUG_DISPLAY',true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

October 31, 2019 at 11:36 am #4863227

hussainB

Ok, but I can see that the Woocommerce Multilingual plugin is deactivated. When activating this again, it makes the whole site shrink as in the picture i sent you.

Should we try again from the beginning and then deactivate the plugin backend, delete it in the wp-content/plugin folder and reinstall it? Like we did with the WPML and add-ons?

October 31, 2019 at 8:06 pm #4867523

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

The activation of Woocommerce multilingual causes a Fatal Error but due to Debug Logging not being enabled the page remains showing.

The reason it shrinks is that what you are seeing should be an error page generated by WordPress, therefore as I mentioned above it takes on the default WP CSS Styling for an error page.

You can see this when you right-click -> Inspect and review the CSS code in the front end.

There is no need to delete the plugins and reinstall them again, we need to review your error log as this would give us a better idea of the error that is being triggered.

1. Please provide me with your FTP details.

2. Were you able to follow the steps i mentioned in my previous post ? Please share your error log with me.

November 1, 2019 at 10:03 pm #4873181

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

I was able to review the error log and most of the warnings/notices within it were due to the Clerk Plugin and WPML Redirect Based on IP Country

NOTE: As these are simply warnings/notices you can enable the plugins again but WP_DEBUG_DISPLAY will need to be set to "false" to remove these warnings from the front end.

Error Log Contents:

Notice: Undefined index: log_enabled in /home/designlett/domains/designletters.com/public_html/stage301019/wp-content/plugins/clerk-woocommerce-2.0.1/includes/class-clerk-admin-settings.php on line 67

[01-Nov-2019 12:36:21 UTC] PHP Warning:  session_start(): Cannot start session when headers already sent in /home/designlett/domains/designletters.com/public_html/stage301019/wp-content/plugins/wpml-auto-detect-and-redirect-by-ip/wpml-auto-detect-and-redirect-by-ip.php on line 119

The page layout issue is caused when the plugin "Really Simple SSL" is activated along with WCML.

With "Really Simple SSL" plugin deactivated and WooCommerce multilingual activated the issue seems to be resolved and the front end shows as expected.

I was able to register the following Fatal Error:

 PHP Fatal error:  Uncaught LogicException: A function must be an instance of \Twig_FunctionInterface or \Twig_SimpleFunction. in /home/designlett/domains/designletters.com/public_html/stage301019/wp-content/plugins/sitepress-multilingual-cms/lib/twig/src/Environment.php:1119
Stack trace:
#0 /home/designlett/domains/designletters.com/public_html/stage301019/wp-content/plugins/woocommerce-multilingual/inc/template-classes/class-wcml-templates-factory.php(80): WPML\Core\Twig\Environment->addFunction(Object(__PHP_Incomplete_Class))
#1 /home/designlett/domains/designletters.com/public_html/stage301019/wp-content/plugins/woocommerce-multilingual/inc/template-classes/class-wcml-templates-factory.php(24): WCML_Templates_Factory->maybe_init_twig()
#2 /home/designlett/domains/designletters.com/public_html/stage301019/wp-content/plugins/woocommerce-multilingual/inc/currencies/currency-switcher/class-wcml-currency-switcher.php(143): WCML_Templates_Factory->get_view()
#3 /home/designlett/domains/designletters.com/public_html/stage301019/wp in /home/designlett/domains/designletters.com/public_html/stage301019/wp-content/plugins/sitepress-multilingual-cms/lib/twig/src/Environment.php on line 1119

This is a known issue and is caused by the currency switcher, after disabling multicurrency and re-enabling it, it seems that the issue was resolved.

Please let me know your results

Errata:
https://wpml.org/errata/visiting-product-page-or-a-page-where-currency-switcher-is-present-could-produce-an-error-with-woocommerce-multilingual-v-4-7-0/

-----------------------

November 4, 2019 at 1:40 pm #4881595

hussainB

Hello,

I followed your instructions on a new staging server - hidden link :
- deactivate Really Simply SSL (keept SSL)
- manuelly deleted WPML plugins, uploaded new plugins and activated
- disable/enable Currency Switcher
- Activate Really Simply SSL again

I further updated other plugins and the woocommerce database. We still need to updata the theme "Flatsome" but are waiting for access to the license key.

I have enabled debug logging on the site. Please see hidden link

Now there is a problem with showing the menu. For menu-items with a dropdown small triangles are now visible (please see attached screen dump).

Could you please check the error log to see if this is caused by the WPML plugins?

Best regards
Mikael

November 4, 2019 at 1:47 pm #4881645

hussainB

Hello,

Adding to the previous reply: I now updated the "Flatsome" theme but the "triangles" are still there.

Best regards
Mikael

November 4, 2019 at 6:45 pm #4884103

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi Mikael,

The menu triangles I believe are pushed down because the "define('WP_DEBUG_DISPLAY') is set to True.

If you switch it to "False", the triangles should show next to the dropdown menu as expected.

If instead, you wish to completely remove the triangles from the menu, some custom CSS will be required.

The arrows are added by the plugin mega menu and are defined by the following CSS class

mega-indicator

If you wish to remove them you can use the following CSS

#mega-menu-wrap-primary #mega-menu-primary li.mega-menu-item-has-children > a.mega-menu-link > span.mega-indicator{
display:none
}

Let me know your results, please.

November 6, 2019 at 1:19 pm #4898805

hussainB

Hello,

Yes, the define('WP_DEBUG_DISPLAY') caused the "triangles" to show.

It is now solved, the WPML Plugins are updated and we are about to remove the Really Simple SSL plugin completely.

But there were some strange errors when we tried to push the staging server to the live server. The menu dissapeared and the "flatsome theme logo" appeared in the menu instead of our own menu.

We have an errormessage regarding taxonomy terms. Could this maybe cause this problem? (see attached image).

I'm basically worried, that WPML might not be setup correctly since the developers that did the work are not working for us any more.

Would you be able to check if the WPML is setup correctly and if this causes some of the problems?

November 6, 2019 at 8:18 pm #4901607

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

I am glad to hear the original issue has now been resolved, I have enabled the private field reply.

The menu logo issue could be due to the migration and the image not switching the URL correctly, what are your results if you add it again manually now in the live environment?

Also, the taxonomies issue can be resolved by following the steps in the notice. Click on Product categories link and synchronize them, then it should be removed.

November 7, 2019 at 8:26 am #4903443

hussainB

My issue is resolved now. Thank you!