This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Bobby 3 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 6, 2019 at 8:11 pm #3971917

vanusap

I made updates to a default page and now I want to update the translated page so it shows the same content. However, when I go to the WPML translation editor, it still shows the outdated content from the default page. I read through the threads about this topic and tried:

- purge cache on all pages
- deactivate all WPML plugins and reactivate them
- clear the pending jobs in the “translation jobs” tab
- mark the translation in the target page as completed (100%), update the default page and go back to translation editor
- delete the target page entirely (both from published pages and trash bin) to start from scratch

However, it still shows me all outdated content for the default page in the translation editor.

Any idea how I can fix it?

June 6, 2019 at 9:46 pm #3972287

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

are you using the WPML Translation Editor, Advanced Translation Editor or the classic WP editor with the page builder to edit your translation ?

is this happening with all translations or just one ?

if possible i would like to take a closer look, which page/post is the one in question ?

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

June 25, 2019 at 7:19 am #4081731

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

i went to the How It Works page and added a small change and updated the page, this allowed me to then add access the translation to update it refreshed.

within the WPML Translation Editor now i do see the default page updated content but the Translation content does not show translated ?

is this the issue you are experiencing ? I can see that if i go to the default language page and use the language switcher to switch to Spanish and stay within the page builder i can view the translations

also if you create a new test page , are you able to reproduce the issue ?

The topic ‘[Closed] Updates on the default language don't show up in translation editor’ is closed to new replies.