This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Hi, Amit here, I am the WPML Support Manager, please make sure you are using the latest WPML 4.3.15 before reporting an issue, thanks!

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This topic contains 40 replies, has 2 voices.

Last updated by peterB-85 3 days, 10 hours ago.

Assigned support staff: Andreas W..

Author Posts
May 19, 2020 at 3:12 pm #6169419

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

I am still confused about how you translated the sliders in first place. Could oyu please provide me more details? Do I understand right, that the fields were available on the backend for all pages and suddenly this was not the case anymore?

I do not see the field groups on any page, even if I translate them or not. I get the same result without Translation Management.

I have now disabled Translation Management, as in fact, if earlier the pages were translated with the native WordPress Manager we could get some issues here.

In fact when opening the WPML Translation Editor for the first time I saw a huge amount of strings, and you should be able to translate the content this way. Even many translations were saved on the interface, but take note that once you use the WPML Translation Editor you should not longer translated content by using the native WordPress Editor.

Means if you edit pages manually in different languges the WPML Translation Editor will not track the changes.

https://wpml.org/documentation/translating-your-contents/how-wpml-keeps-track-of-your-translations/

Kind regards
Andreas

May 19, 2020 at 5:08 pm #6170501

peterB-85

Hi,

I am not sure what happened to the fields. They were there before prior to your previous update. I can restore from a backup on Friday and they should return.

For the translations, we just utilize WPML to manage the pages (the initial copy of English to the pages for each language) and the switcher functionality. After the page for the language is created, we manually translate the page in that language. From there, the pages should work independently. That is why it is odd that one homepage slider edit is affecting another language's homepage slider when it hadn't before. We really only use WPML for those simple functions and not to keep translations inline between languages. We would rather handle that manually.

Should I restore from Friday's back up to get those fields back and we work from there with that context in mind? Thanks!

May 20, 2020 at 3:25 am #6173285

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

This is a kind of odd issue, as I did currently not find any similar reported case, so far.

I have created a new test site with WPML pre-installed. Sadly I do not have access to the latest version of ACF PRO which for I would like to ask you to install it here for testing:

One-Click-Login:
hidden link

On your site, I also tried downgrading to ACFML 1.6.0, and tested a minimal setup but with the same results.

Are you refering to the WPML CMS Multilingual 4.3.12 Update that cause the issue? If so please check tomorrow for a new update that should get released over the day and verify if the issue persit afterwards.

I would also suggest testing if the issue persists when using a default theme liek TwentyTwenty as the issue might be theme related.

I then realized that the WP Memory Limit is set too low and tried to change but sadly the server is not responding to my FTP access request.

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Please leave me a short notification once ACF PRO is installed on the test-site.

Kind regards
Andreas

May 20, 2020 at 1:24 pm #6178177

peterB-85

Ok, thank you. I have added a copy of ACF Pro to your install and I will make the rest of your suggestions.

May 20, 2020 at 4:10 pm #6179445

peterB-85

It looks like it might be best for me to at least revert back to Friday's backup. The fields seem to be a mess now and tied only to English. I tried making them available to UK English and some fields won't work with that language at all. I will restore from back up and add the memory limit setting back in.

May 20, 2020 at 5:10 pm #6179925

peterB-85

Hello, just an update: I have restored the site to Friday's backup, added the 256mb memory limit, and also updated the plugins to the newly released versions. From there, I changed the settings to the fields in the slider to "Don't translate" (screenshot attached, let me know if that setting makes sense for this to work the way we want it to). After doing that, the slider seems to be functioning properly. I am optimistic but it seemed to have been working before and then we had the issues again. We are going to run some tests to be sure and I will get back to you.

May 20, 2020 at 9:18 pm #6181393

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Interesting, so now with Translation Management while having the fields set to "not translated" you can see them on all pages in the backend and can edit in all languages accordingly?

Those field groups are not translated or are they? Please provid eme some feedback about that as it might be very helpful for other clients in the same situation.

I would say, as with the latest plugin versions and current config it is working please test for a couple days and get back to us if the issue occurs again.

Kind regards
Andreas

May 20, 2020 at 9:30 pm #6181433

peterB-85

We may have had the issue again. We updated all pages but once we updated the slides on the UK English homepage, it deleted the slides on the other languages. It is possible that it could have been a cache issue as it only happened once so far. So we will keep testing. I was thinking about this further. What we literally want is to not have any of the content to be automatically translated between language pages once the language pages have been created/copied from English. After the pages have been created for another language, we manually update the content and language for that page. So there is no need for the pages to have settings where when one is updated, the other will be updated too. We will manually update the other pages if needed. So is there a setting that makes sure a page in another language is only manually updated and not trying to be an exact translation of the equivalent US page? Thanks!

May 21, 2020 at 8:16 am #6184349

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I do sadly not have access to your site anymore.

Until now, I am still confused about how you handled the translation in first place.

Could you please recreate the issue on the following test-site?

One-Click-Login:
hidden link

Please test if you can recreate the issue here and I will be glad to assist you. Take note that you can export and import field groups at Custom Fields -> Tools and then upload them towards the test-site.

In case the issue will not be replicable we will need to investigate further.

Also take note that there been updates for our plugins since yesterday. It would be worth testing with the latest versions which I installed on the test-site already.

Now, about your question I would usually:

1) Translate the field group in order to have the fields available in all languages on the native WordPress Editor
2) Config the fields to be not translatable in order to not show up inside the WPML Translation Editor.
3) Then edit the fields on each language on the native WordPress Editor while still using the WPML Translation Editor to translate pages.

Now, in your case the WPML Translation Editor was not used at all in first place, correct?

Did the issue with the deleted slides only happen when editing the UK English homepage?
Was this page maybe a WPML duplicate which was synced with the default US version?

Example:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Kind regards
Andreas

May 21, 2020 at 5:33 pm #6188977

peterB-85

Hello, I just tried the display untranslated content from the instructions you sent through that link. The process overwrote the content on the translated home pages, so I had to manually update that content for each language. When I did that for each language, I made sure to first press the "Translate Independently" button. After all that, I then started updating slides. Things seemed to be going good but once I added some slides in "UK English", all the slides in the other languages were deleted.

Yes, right now, adding slides to the "UK English" seems to be a consistent way to test this but we had issues when updating German or US as well in the past (very random). One thing I noticed when looking in the Translation Management area, it still looked like WPML was try to translate updates between home page languages, even though I set each page to be "Translated Independently".

The rest of the content on the pages seem unaffected, only the slider, which is managed using the ACF repeater field. It is frustrating because this issue didn't exist until recently, so it must have been a plugin update of some sort that is causing this.

I am not sure how your login info was removed, possibly from the backup restore, but I have added you back, so you can log in. FTP should still work too. If you add a few slides to French, a few slides, to German, a few slides to Portuguese, and then UK, checking the live site after each language update, you should be able to replicate the issue. After updating those and it seems to be fine, then add slides to US. Then update between US and UK and sooner than later the slides in other languages will be affected. The issue will most certainly happen.

If we can't fix this or find the reason this is happening, I have a developer starting next week who will take over for me to help get this settled. Thanks again for your help.

May 22, 2020 at 9:15 am #6193669

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

My apologies for the delay on answering. I have taken a new copy of the site for further investiagation.

Saldy, the first migration is failing. I will need to start the progress over again and will get back to you later.

I hope this is fine with you?

Kind regards
Andreas

May 22, 2020 at 12:54 pm #6195553

peterB-85

That is no problem. Thank you.

May 23, 2020 at 6:14 am #6199793

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your patience while I been checking your site's copy.

First, I was surprised why here the field groups are showing up on all pages as those groups are not translated, but I can see that also on my test-site this is now default behavior.

I am following up with my colleagues about that.

Then, first I realized that at WPML -> Settings -> Post Type Translation -> Pages the option "Translatable - use translation if available or fallback to default language" is set. This would mean that if we do not have a translation we will display original content (English US).

I have set this option to "Translatable - only show translated items" instead to avoid language fallbacks.

In the field group "Homepage" various translation preference settings were set to "Translate". I adjusted them all to "Don't translate" as we want to edit the fields on each language independently and we will not use the WPML Translation Editor.

Further, on the WordPress native page editor, at the bottom inside the section Multilingual Content Setup I set the option "Make 'Pages' translatable" instead of currently "Make 'Pages' appear as translated".

Then I started some translation tests, by adding a different slider to each homepage to the section HOMEPAGE -> HERO -> SLIDES. I added the content seperately for each language without using the WPML Translation Editor.

This worked fine for EN-US and EN-GB with different content in each language. Then I updated EN-US by editing the first slide texts and adding a second slide. I saved the page and checked the US and GB Front-End and Backend where everything was looking as expected. Also adding a second slider to EN-GB was not an issue.

I hope I recreated this correctly, and it seems with the applied configuration everything is working proper.

Let me know if you do have any questions. I can also provide you a copy of my localhost test-site copy, if you wish to have a look at it.

Kind regards
Andreas

May 23, 2020 at 12:19 pm #6200981

peterB-85

Ok thank you Andreas. I will try it out. Some of those settings may have been like that from me testing what could work. I’ll also record my screen so that if the issue remains, I can share it. Fingers crossed!

May 24, 2020 at 3:17 am #6202961

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

This should work out, as I tested it with a exact copy of your site on localhost and I did not do much more than adjust the mentioned settings.

By the way, the Slider look great, only on first page load sometimes they appear not as slides, but as single images all over the page for about a second. This seems not WPML realted and might get solved after setting a higher WP Memory Limit.

Your current values are:

PHP MemoryLimit 512M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Let me know if further assistance is needed.

Kind regards
Andreas