This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Alejandro 3 months, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
June 25, 2019 at 7:49 am #4082035

jaapd-2

Hi,

I'm trying to update WPML components to the latest version but once again it fails.
Normally I update plugins with InfiniteWP. I see this error when updating WPML component:

PHP Fatal error occurred: Uncaught Error: Call to undefined function icl_get_string_id() in /subdomains/clixtest/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-wc-strings.php:454 Stack trace: #0 /subdomains/clixtest/wp-includes/class-wp-hook.php(286): WCML_WC_Strings->translate_attribute_taxonomies_labels(Array) #1 /subdomains/clixtest/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array) #2 /subdomains/clixtest/wp-content/plugins/woocommerce/includes/wc-attribute-functions.php(73): apply_filters('woocommerce_att...', Array) #3 /subdomains/clixtest/wp-content/plugins/woocommerce/includes/admin/wc-admin-functions.php(47): wc_get_attribute_taxonomies() #4 /subdomains/clixtest/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-help.php(35): wc_get_screen_ids() #5 /subdomains/clixtest/wp-includes/class-wp-hook.php(286): WC_Admin_Help->add_tabs(Object(WP_Screen)) #6 /subdomains/clixtest/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #7 /subdomains/clixtest/wp-includes/plugin.php(46 in /subdomains/clixtest/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-wc-strings.php on line 454.

When I do a manual update I also get an error. See screenshot.

This happens more. The only way to solve it i by manually placing the new files with FTP. You can imagine that this takes a long time since I'm managing 10+ WPML websites. And most of them show this issue once in a while.

Can this be solved please?

Cheers,
Jaap

June 25, 2019 at 8:53 am #4082389

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

Can you press the button that says "Updates checken" in Plugins > Add New > Commercial (that button appears in the screenshot you sent me).

Then try to update again.

Let me know how it goes.

June 25, 2019 at 9:56 am #4082933

jaapd-2

Hi,

I can press the check for updates button. It refreshes the screen. When I try to update components after that I get the same error.

Cheers,
Jaap

June 25, 2019 at 10:58 am #4083553

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Could you momentarily disable the security plugins (i noted you have both ithemes and sucuri security), then flush and disable your wp-rocket cache and try again.

Please follow the instructions mentioned on this page: https://wpml.org/documentation/support/debugging-wpml/

Try to recreate the problem once you have added those lines to your wp-config.php file and then go to your installation's wp-content folder and find the "debug.log" file that should've appeared by now (it will appear if it enocunters an error in your server).

When you're recreating the problem please open your browser's inspector ( https://www.lifewire.com/get-inspect-element-tool-for-browser-756549 ) and see if you get any issue.

I think this cproblem could be caused because of a timeout error, because i see that your timeout is set to 0, which usually isn't an issue but in most cases it's better to have a defined value in there, something like 90 or 100s would allow your system to have enough time to do everything.

If you want to increase this value you can try to add this code in your wp-config.php file:

set_time_limit(90);

And then you can verify if the value has changed by going to WPML > Support (there will be a value called "TimeLimit", which should have the new value now.

Let me know if this helped.

June 25, 2019 at 11:26 am #4083787

jaapd-2

Hi,

I enabled debugging but no log is created. There's also no information in the console.
See: hidden link

The time limit of 90 is also not visible on the page you've mentioned.

Cheers,
Jaap

June 25, 2019 at 4:58 pm #4086349

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

At this point, could you grant me access to your site so i can take a closer look at it?
I just enabled the fields for it. please add them there so the credentials stay safe and private.

Regards.

June 27, 2019 at 2:26 pm #4100809

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Can you try to go to Dashboard > Update > Press "Check Again" button > Try to update

Unfortunately i couldn't try that because i don't seem to have access to that page.

Apart from that, it seems like something's blocking the update request because it says the update has failed almost as soon as you click it (at least on my end).

Could you try to disable your security and maybe the infiniteWP plugin for a moment and see if that helps?

If it does, let me know so i can understand how to proceed.

June 27, 2019 at 3:06 pm #4101153

jaapd-2

Hi,

It's a test environment, you can disable any plugin if you want. Go ahead 🙂

Cheers, Jaap

June 27, 2019 at 4:50 pm #4101689

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

The problem was solved by deactivating and activating the managed hosting plugin, i don't really know why, but after disabling it and enabling it, i could correctly update all the plugins without further issues (i updated one from the plugin list, 2 from the commercial tab).