This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to update the plugin and add my key but it says its invalid.

Solution: Please follow below steps:

- Please backup your database and website - Deactivate the existing WPML plugin and add-ons. - Delete the plugin files – this does not delete your translations. You will just delete the plugin files from your "wp-content/plugins" folder, all your data will be kept saved.

- Install and activate WPML again. You can download it from your account: https://wpml.org/account/downloads/

- Again register WPML in your site and enter the new key: Please Login to your WPML account >> go to Sites page >> Remove your current site / domain from there >> and re-add your site >> it will give you New key which you can add back in your site: https://wpml.org/account/sites/

This topic contains 4 replies, has 2 voices.

Last updated by cloudeon-asC 6 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
March 26, 2019 at 2:06 pm #3463227

cloudeon-asC

I am trying to update the plugin and add my key but it says its invalid

March 26, 2019 at 3:38 pm #3464199

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

- Please backup your database and website
- Deactivate the existing WPML plugin and add-ons.
- Delete the plugin files – this does not delete your translations. You will just delete the plugin files from your "wp-content/plugins" folder, all your data will be kept saved.
- Install and activate WPML again. You can download it from your account: https://wpml.org/account/downloads/
- Again register WPML in your site and enter the new key:
Please Login to your WPML account >> go to Sites page >> Remove your current site / domain from there >> and re-add your site >> it will give you New key which you can add back in your site: https://wpml.org/account/sites/

Thank you

March 27, 2019 at 8:01 am #3468329
cloudeon-asC

Hi,

So I have done as you suggested, removed the plugin and added the new one. No my language selector doesn't work. hidden link

I can see that the pages are there if I change the directory in the url but the selector that was working does not work. Is there something that we need to do to get it to work?

I can see in the backend " WPML needs to set languages to existing media in your site. Set media languages" <- Does this have something to do with it?

I really hope you can help!

Thanks

March 27, 2019 at 9:00 am #3468821

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To handle language switcher and media setting issue, I have created a new ticket. Here is the link to the new ticket:
https://wpml.org/forums/topic/language-selector-doesnt-work-and-wpml-needs-to-set-languages-to-existing-media/

You may mark this current ticket as resolved and we will continue to work on the new ticket.

Thank you for your cooperation and patience.

April 16, 2019 at 7:33 am #3619035

cloudeon-asC

My issue is resolved now. Thank you!