This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Nick 3 months, 2 weeks ago.

Assigned support staff: Vincenzo.

Author Posts
March 20, 2019 at 3:48 pm #3390071

Nick

For updating WordPress and plugins we use SSH2. When the "WPML Multilingual CMS" plugin is enabled it is not possible to update any of this because of permission issues ("Installation failed: Could not create directory"). When disabling "WPML Multilingual CMS" it is possible to update WordPress and plugins.

We have also tested this situation in the default twentynineteen theme. Can you check this issue please?

Thanks in advance.

March 21, 2019 at 9:05 am #3397129

herko

I've noticed the same issue and reported this in https://wpml.org/forums/topic/wordpress-will-not-update-or-update-other-plugins-with-wpml-active/

March 21, 2019 at 9:13 am #3397165

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

I am going to reproduce this issue on my test server so I can escalate to our developers.

In the meantime, to speed up the process, it would be very useful if you could send me a detailed list of the steps that you used to replicate the problem.

Thank you

March 21, 2019 at 1:31 pm #3404817

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

this seems like a known issue with the recent version of WPML String Translation plugin.

More details in this Spanish ticket:
- https://wpml.org/es/forums/topic/wpml-string-translation-afecta-al-sistema-ftp-de-wordpress/

To verify if this is the same issue, can you please tell me if the issue is reproducible when String Translation is disabled?

Thank you

March 21, 2019 at 2:09 pm #3406697

Nick

Hi Vincenzo,

I can verify it is the same issue. When String Translation is disabled updating plugins seems te work fine.

March 21, 2019 at 3:19 pm #3409567

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thank you for your confirmation.

I asked to increase the priority of the internal ticket.

I will inform you as soon as this issue will be solved or when a workaround will be available.

Thanks for your patience

May 2, 2019 at 2:07 pm #3725379

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

the issue has been fixed. The fix should be available in the next major versions of WPML plugins.

I will keep you updated.

Thanks for your patience

May 3, 2019 at 2:38 pm #3735565

Nick

Hi Vincenzo,

Great! Thanks for keeping me updated. 🙂

July 1, 2019 at 9:54 am #4117547

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

can you please verify if the issue has been solved with the latest versions of String Translation?

Thank you!

July 2, 2019 at 8:22 am #4124931

Nick

Hi Vincenzo,

My issue is resolved now. Thank you! 🙂