This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 3 voices.

Last updated by Adriano 1 year, 2 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
August 2, 2018 at 4:50 pm

danielD-8

This started happening after we updated the WPML plugin to 4.0.5 (on July 24th).

Whenever we upload an image, it does not show it in our media library either our main one (spanish) or secondary one (english).

A workaround was to go to WPML support > troubleshooting > and doing the fixing, clearing cache, etc... Only then could we see all the images (the ones after the 24th will only show in our main language's media library).

This allows us to see up to the latest image in our Media Library's main language. However, it would not fix the issue. When creating a new post and adding an image, it will not show in the media Library, forcing us to upload the image twice (one for spanish, one for english).

August 3, 2018 at 9:48 am #2608749

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

This seems unusual as the images should be uploaded without any problem, it seems like a theme/plugin conflict or a PHP error that is blocking some functionalities and creating such issues, so could you please perform the below steps and let me know if that helps?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

August 3, 2018 at 1:36 pm #2609875

danielD-8

Thanks Shekar,

I disabled all the plugins except wpml, set the theme to a default wordpress theme and the problem still persists. I found out that when this happens, I can go and click on WPML support > troubleshooting > "Set language information" (Adds language information to posts and taxonomies that are missing this information.) and then the uploaded image becomes visible. But does not fix it. If I upload another image, it won't show. Debug info:

August 6, 2018 at 10:39 am #2615434

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Glad to know that you find a workaround for now.

To further debug this issue, I would need to replicate this site on my localhost and perform further debugging, I tried to create a package using duplicator but to server restrictions I couldn't build it, so could you please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me. You can edit your previous private reply to send me the updated links.

Look forward to your reply.

Thanks

August 6, 2018 at 4:42 pm #2616742

danielD-8

Hi Shekhar,

I don't see an option to edit my previous reply. How can I edit the message or how can I send you the link privately?

August 7, 2018 at 3:50 am #2618425

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have enabled the private reply so please send the details in the next reply.

Thanks

August 7, 2018 at 12:56 pm
August 8, 2018 at 4:35 am #2622732

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please provide me access to the duplicator package?

Look forward to your reply.

Thanks

August 8, 2018 at 2:02 pm #2625019

danielD-8

Shared, thanks.

August 9, 2018 at 1:22 pm #2628977

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I uploaded the images and its showing perfectly in the media library so could you please check the issue further?

Look forward to your reply.

Thanks

August 10, 2018 at 6:06 pm #2635037

danielD-8

That is the reason I asked for support. Wasted all my time just to tell me to "check the issue further"? was expecting more from support.

August 13, 2018 at 4:08 am #2638822

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am sorry if the suggestion wasn't much help, I tried to replicate the issue on your end and it was working so I am wondering if it was fixed, that's the reason I asked you to check once again.

Also, I can see that WPML media translation plugin is not enabled on your site, so could you please enable it.

Look forward to your reply.

Thanks

August 13, 2018 at 4:58 pm #2640659

danielD-8

I had disabled Media translation because images would not show up on our secondary language gallery. When I enable Media translation the Media Gallery problem goes away but then the old problem of not showing images comes back. Images dissappear from the gallery in this page:
hidden link

As compared to this page:
hidden link

August 14, 2018 at 12:41 pm #2643387

Adriano
Supporter

Hi Daniel,

This is Adriano, WPML Developer. I've done a few tests locally and it looks like the issue is solved in the current development version. Anyway, a few guidelines that may help you to understand how Media Translation is working in 4.0.5:

We have added a few settings in WPML > Settings > Media Translation section. Please have a look if all settings are well configured.

After that, once you upload a new image, it will be present in all languages. Then when activating WPML Media you will be able to translate them in WPML > Media Translation screen.

Please let me know if it helps.

August 14, 2018 at 4:29 pm #2643976

danielD-8

Thanks Adriano, what about the images I have already uploaded? As you can see in the screenshots, The images on a gallery are visible in the back end on the page but not visible in the front end.

Even when I upload a new image into that gallery it does not show up on the front end, only the back end.