This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.19 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Jobs on the Translation Jobs tab cannot be canceled. The following message shows when you hover the X icon:

You can only cancel local jobs

Solution:

Here is how you can fix it.

1. Go to WPML -> String Translation.

2. Find the string 'Local' under the domain 'wpml-translation-management'

3. Translate this string into 'Local'

The problem was that it was translated into the default language on your site.

4. Select the 'Use my translation' checkbox and press the 'Save' button.

Now you should be able to cancel the jobs if they are not finished, of course.

This topic contains 19 replies, has 2 voices.

Last updated by Adam Rosenfeld 5 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
April 15, 2019 at 10:12 am #3612303

Adam Rosenfeld

I am trying to:

Access and complete translations for two Gravity Forms.

Link to a page where the issue can be seen:

I expected to see:

The ability to access a Gravity Forms translation in Translation Management.

Instead, I got:

The form says "Waiting for translator" and no one can access it.

April 15, 2019 at 10:41 am #3612555

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Adam.

By looking at the debug information that you have attached to this ticket, I can see that you are using the latest versions of Gravity Forms and Gravity Forms Multilingual, but WPML and its other add-0ins are not updated on your site.
Could you please update WPML and its add-ons on your site and check if the issue persists?

Thanks,
Itamar.

April 15, 2019 at 11:41 am #3613135

Adam Rosenfeld

Thanks, WPML is updated. Toolset is not, but I removed the Toolset license from this site because I wanted to use it for another site. Toolset is not being used with any of the pages or Gravity Forms in question.

Is there a way to move to chat. I'm in Israel too 🙂

April 15, 2019 at 11:42 am #3613139

Adam Rosenfeld

Thanks, WPML is updated. Toolset is not, but I removed the Toolset license from this site because I wanted to use it for another site. Toolset is not being used with any of the pages or Gravity Forms in question.

Is there a way to move to chat? I'm in Israel too 🙂

April 15, 2019 at 12:44 pm #3613495

Adam Rosenfeld

Hi this is an urgent matter, is it possible to receive chat support?

April 15, 2019 at 2:18 pm #3613967

Adam Rosenfeld

We were hoping to launch registration for an event today. We told people registration would open tomorrow.

If there's any way to get chat support tomorrow morning (from 9:30) Israel time, it would be much appreciated. Thanks.

April 16, 2019 at 8:25 am #3619713

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm online now. If you want, please start a chat. If I'm not the one who gets to answer this chat you can ask for me. But also any other of my colleagues would be able to help you. I cannot turn this ticket back into a chat so if you want to continue here, please reply here. I'm enabling private message for the next reply so you can share the access to your site with me. Please explain to how I can see the issue on your website.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

April 16, 2019 at 9:00 am #3620187

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Great, I'm glad that it is solved now!
Good luck with your web projects 🙂
Itamar.

Cheers,
Itamar.

April 16, 2019 at 10:59 am #3621187

Adam Rosenfeld

Hi. Once again, I cannot cancel local translation jobs. If you look at the attached image, I am getting a grey "x" when I should be seeing an orange "x".

April 16, 2019 at 2:16 pm #3622881

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Adam.

Are those the same Gravity Forms that you couldn't access their translations earlier?

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

April 17, 2019 at 4:31 pm #3632957

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I've checked the Translation Management section on your site and I cannot see the Translation Jobs anymore. Please see the attached screenshot.
Have you already solved this issue of not being able to cancel the Translation Jobs?

Regards,
Itamar.

April 18, 2019 at 6:47 am #3636369

Adam Rosenfeld

Hi, I now gave you access as a Translation Manager. You should be able to see the translation jobs tab now. Also, I still cannot cancel translation jobs. Thanks.

April 18, 2019 at 1:06 pm #3639307

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for adding me as a Translation Manager.

I can now see the problem on your site. It seems as if WPML treat those jobs (all the jobs on your site) not as local jobs. Please see the attached screenshot not-local-job.jpg. Maybe WPML treats them as Translation Service jobs. I can see that currently none of the Translation Services is chosen on your site. But please let me ask you if in the past you enabled a Translation Service and then canceled it moved to translate your content with local translators?

I've tried to see what happens with a new post that is sent to translation. For this, I created a test post and called (פוסט ניסיון). The same happens with new posts. Please see the attached screenshot test-post.jpg. I'm also consulting our second tier supporters about this issue.

Meanwhile also, please try the following.
I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated except WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example). If it persists then deactivate all plugins except the WPML and its add-ons and WooCommerce itself. Then please check if the problem persists. If it does not persist so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Please let me know what have you found out. I'll also get back to you here when I have a reply from out second-tier supporters.

Thanks,
Itamar.

April 18, 2019 at 1:26 pm #3639451

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Oh! and one more important thing that I've just noticed. You told me that you have updated WPML to its latest version but I can see now that it is not updated. Please see the attached screenshot wpml-not-update.jpg. You can update WPML on your site here.
hidden link
Could you please update WPML and tell me if it solves the issue?

Thanks,
Itamar.

April 21, 2019 at 7:45 am #3651857

Adam Rosenfeld

Thanks.

I created a staging site.

I switched to the Twenty Seventeen theme.

I deactivated all plugins except for WPML plugins.

The problem is still there - I can't cancel local jobs.