This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 17 replies, has 2 voices.

Last updated by Vincenzo 5 months, 4 weeks ago.

Assigned support staff: Vincenzo.

Author Posts
April 12, 2019 at 4:12 pm

edwardH-9

I am trying to: access wordpress dashboard

Link to a page where the issue can be seen: hidden link

I expected to see: login and dashboard

Instead, I got: When WPML plugin is activated I get a http error 500 this is very recent everything was fine before. I deactivate the plugin and I am able to access the dashboard and wordpress no problems. Right now I have renamed the sitepress-multilingual-cms folder in plugins to sitepress-multilingual-cms123... in order to be able to access wordpress.. but this means I am unable to provide debug info..

April 12, 2019 at 4:50 pm #3600745

edwardH-9

For whatever reason duplicator is stuck at 59%...

April 12, 2019 at 5:28 pm #3600933

edwardH-9

I have re-downloaded and copied files via ftp to my site and I am still having this issue. I really need help asap with this I am losing calls.. my business cannot run like this.

April 12, 2019 at 8:59 pm #3601977

edwardH-9

Seems like an issue with string translation and translation management
Fatal error: Uncaught Error: Class 'WPML_Option_Manager' not found in /home/soluti23/public_html/wp-content/plugins/wpml-translation-management/classes/ATE/Hooks/class-wpml-tm-ams-check-website-id-factory.php:9 Stack trace: #0 /home/soluti23/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php(92): WPML_TM_AMS_Check_Website_ID_Factory->create() #1 /home/soluti23/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php(56): WPML_Action_Filter_Loader->run_factory(Object(WPML_TM_AMS_Check_Website_ID_Factory)) #2 /home/soluti23/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php(30): WPML_Action_Filter_Loader->load_factory('WPML_TM_AMS_Che...') #3 /home/soluti23/public_html/wp-content/plugins/wpml-translation-management/plugin.php(178): WPML_Action_Filter_Loader->load(Array) #4 /home/soluti23/public_html/wp-includes/class- in /home/soluti23/public_html/wp-content/plugins/wpml-translation-management/classes/ATE/Hooks/class-wpml-tm-ams-check-website-id-factory.php on line 9

April 12, 2019 at 9:40 pm #3602069

edwardH-9

With further digging I commented out the following :
if ( $name === '' ) {
throw new InvalidArgumentException( 'Translation name cannot be empty' );
}

in the wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php

and turned off show error in php.ini editor in cpanel and everything seems to work for the moment.

I still would like to know why this happened and how to resolve permanetely

Thank you

April 13, 2019 at 10:12 am #3604285

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

1. Can you please confirm that you are using the latest versions of WPML and its active add-ons?
You can check the latest released versions under “My Account -> Downloads” on this site.
- https://wpml.org/account/downloads/

2. Can you please paste your WPML Debug information in the Debug information field?
- https://wpml.org/faq/provide-debug-information-faster-support/

Thank you

April 13, 2019 at 3:30 pm #3605035

edwardH-9

WPML Multilingual CMS Installé Oui 4.2.5
WPML CMS Nav Installé Oui 1.5.0
WPML String Translation Installé Oui 2.10.3
WPML Sticky Links Installé Oui 1.5.0
WPML Translation Management Installé Oui 2.8.4
WPML Media Installé Oui 2.5.1
WooCommerce Multilingual Non installé Non n/a
Gravity Forms Multilingual Non installé Non n/a
Yoast SEO Multilingual Non installé Non n/a
PHP
Version
7.2.17
Limite de mémoire
1024M
Utilisation de la mémoire
91.90 MB
Temps d'exécution max.
259200
Max input vars
10000
Jeu de caractères Utf8mb4
Oui
Extension de chaîne multioctet
Chargée
Extension SimpleXML
Chargée

WordPress
Version 5.1.1
Multisite Non
Limite de mémoire
1024M
Limite de mémoire max.
1024M

Here is all the information that I could give you...

April 13, 2019 at 3:31 pm #3605037

edwardH-9

I also supplied you with the debug information, I was able to obtain it after my make shift work around. As per above message about modifying the wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php file

April 13, 2019 at 4:20 pm #3605127

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

thank you for the debug info.

The error message is related to the Advanced Translation Editor but I can see that on the site you are using the Classic Translation Editor.

1. Did you use the Advanced Translation Editor in the past?

2. In the last few days, we had an issue with a similar symptom (500 server error when accessing the Dashboard).
This issue was solved by temporarily disabling WPML and following these steps:
- Go to Dashboard -> Updates
- Press the "Check again" button
- Scroll to the bottom and press the "Update" button

3. Can you please clear all the server cache and temporarily disable the server cache?
- Is the issue still there?

Thank you

April 13, 2019 at 5:27 pm #3605301

edwardH-9

1- I may have had Advanced Translation Editor activated in the past yes..

Ok here is what I did ;

2- I disabled all WMPL plugins
Went to updates
Checked again (no new updates available)
I reinstalled WordPress version 5.1.1–fr_FR
If I put back in place the class-wpml-st-page-translation.php and leave the line as intended I get the 500 error:
if ( $name === '' ) {
throw new InvalidArgumentException( 'Translation name cannot be empty' );
}
in the wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php

If I comment that section out the site is working again.

3- I purged all caches with w3 total cache.. not sure where I would do so in cpanel and my access to the whm is limited as I am on a shared server..

Issue still persists as long as the wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php has that section commented out it works but if it is left in there it gives me a 500 error...

April 13, 2019 at 5:37 pm #3605317

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thank you for the detailed answer.

It seems like there is a small issue in the database.

1. Please try these steps:
❌ Before proceeding please make a full website backup! ❌

- Go to WPML -> Support Troubleshooting
- Press the following buttons:
- "Clear the cache in WPML"
- "Remove ghost entries from the translation tables"
- "Fix element_type collation"
- "Fix WPML tables collation"
- "Assign translation status to duplicated content"
- "Set language information"
- "Fix terms count"
- "Fix post type assignment for translations"

2. If the issue is still there, to further debug the problem I’d like to replicate your site locally.

I would need a site snapshot if possible.
We usually recommend the free Plugin “Duplicator” for this purpose.

If you already know how Duplicator works
(https://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the archive file you downloaded.

★ Duplicator Instructions
hidden link
https://wpml.org/faq/provide-supporters-copy-site/

If the file is too large (more than 500M), please use the Duplicator file filters to remove the cache, the wp-uploads directory, the media, and the archive files.

Send me the link to the archive file (you probably want to use Google Drive, Dropbox, or similar services, as the snapshot file will be quite big)

Your next reply will be private, which means that only you and I will be able to see it and have access to it. You can paste the link to the file there. You can also share the credentials to your website. I will then download the file from the admin panel.
Once the problem is resolved I will delete the local site.

Please let me know if you need help creating the Duplicator package.

If the Duplicator plugin is not working on your site, you can send me the database dump and a zip file containing all the site's file except the /wp-content/uploads/ folder

Thank you

April 13, 2019 at 5:39 pm #3605319

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

please check also the solution on this ticket:
- https://wpml.org/forums/topic/php-fatal-error-uncaught-invalidargumentexception-translation-name-cannot-be/

Thank you

April 13, 2019 at 6:10 pm
April 13, 2019 at 7:10 pm #3605437

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

1. Did you try the solution in my previous answer?

2. A Cpanel site backup should work. Please add the link into the next private answer.

Please note that I will start working on it on Monday.

Thank you

April 13, 2019 at 7:45 pm

The topic ‘[Closed] **Urgent!!** SITE DOWN – Unable to access wordpress when wpml is activated’ is closed to new replies.