Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Yvette 1 year, 2 months ago.

Assigned support staff: Yvette.

Author Posts
May 24, 2019 at 9:14 am


We have a small site in production, with about 60 posts and 20 pages, in seven different languages. Note we have 250.000 users so far.

Our problem is that the icl_string_pages table has been growing steadily over the past six months, and it is currently at 7.5M+ rows.

We have noticed a significant performance degradation, for now mainly with the back-office, when accessing pages and posts. It takes 30-60 seconds to load the pages/posts page in the wordpress dashboard and to edit their content.

We've tried the following:

- Cleaning WPML cache
- Delete orphaned translations
- Disabling and re-enabilng the String Translation plugin
- Disabling string tracking and auto-registration

None of the above worked, and disabling/enabling the String Translation plugin takes roughly 10 minutes per each action.

Can you please advise on how to clean this table and prevent it from growing in the future?
We would gladly provide access to Duplicator, but it takes forever to back-up and transfer the whole database.

May 24, 2019 at 10:25 am #3883495


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)


Curiously, this table is a type of "cache" to improve performance.

Here is what I would try:
1. Take a database backup
2. Go to WPML > Support > Troubleshooting
3. Select option to recreate the ST DB cache tables
4. If this does not "recreate" from scratch the tables, you might go in directly to the database and remove it...then use the tool to recreate the ST DB cache tables.

Once the table is recreated and a manageable size - we can then see what is beign put into it....

Does this sound like a reasonable approach?

May 30, 2019 at 10:40 pm #3926427


Thank you Yvette, after recreating the ST DB cache tables, the performance improved greatly.

Unfortunately, a few minutes later, I have already 10k records inside the wp_icl_string_pages table.

Do you know what can be causing this issue?

May 31, 2019 at 5:34 am #3927805


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

In this case, please follow the recommendations here so I can forward the info to our 2nd tier supporters who have more experience in performance problems:

Please don´t forget to include all screens of output in your next reply. If there is a lot you might need to upload them to a file sharing service and then send me a download link.

I will also try to see what entries are being loaded into the cache.

May 31, 2019 at 9:43 am #3929325


Hi Yvette,

Many thanks for the quick reply, I think I've found the culprit, I am attaching a screenshot.

Can we disable the BackupBuddy plugin translation in order to improve performance in any way?


May 31, 2019 at 10:02 am #3929599


Also, please find the complete list of queries as per your request:

June 3, 2019 at 11:21 am #3941869


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Normally by not checking the associated text domain for "backupbuddy" in the configuration option, the strings would not be loaded:
WPML > String Translations > Auto-register strings for translation > Edit

1. Is there any way to be able to see the contents of your database using your cPanel database admin tool?

2. Debug Objects output
Please review this section of the article:

We are expecting the results of the 3 tabs of informaiton - not just the DB Queries... could you please send the rest along?

Thank you.

The topic ‘[Closed] URGENT Table icl_string_pages has 7.5M record for 60 posts/20 pages blog’ is closed to new replies.