Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bobby 1 year, 2 months ago.

Assigned support staff: Bobby.

Author Posts
July 28, 2020 at 6:35 pm #6694833

christopheP-3

I have a button with a link that opens a page manually, not a WP page. It switches the url to something else for some reason. If I deactivate WPML the link is correct. It's like it's redirecting to something else.

July 29, 2020 at 3:03 am #6696477

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

please test activating WPML with WPML String Translation deactivated, does the URL still change?

If no, reactivate WPML String Translation and search for the URL of the button within String Translation in case there is a translation added for it.

Also, how are you adding this button? Is it a hardcoded external url?

July 29, 2020 at 5:12 pm #6702251

christopheP-3

Same when I activate wpml but disable string translations. I was using enfold shortcode button but switched to html and it does the same so in string translations I have this:

<div class="avia-button-wrap avia-button-center avia-builder-el-1 el_after_av_button el_before_av_heading "><a href="hidden link" class="avia-button avia-color-theme-color avia-icon_select-yes-left-icon avia-size-large avia-position-center " target="_blank"><span class="avia_button_icon avia_button_icon_left " aria-hidden="true" data-av_icon="" data-av_iconfont="entypo-fontello"></span><span class="avia_iconbox_title">Click Here to Use Our Image Resizer</span></a></div>

but the link it opens is: hidden link which is not the page I'm trying to open but the feature image link of that post.

I also tried a simple text link with the same url. It's that specific url that redirects and I don't see anything where it's different.

It only works if I deactivate wmpl. I even tried to ad a redirect in htaccess and it's not working either.

July 29, 2020 at 7:42 pm #6703003

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Where can I find this link in the front end?

I would like to request temporary access (wp-admin and FTP) to your site to test the issue.
(preferably to a test site where the problem has been replicated if possible)

**Before we proceed I recommend taking FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose: http://wordpress.org/plugins/duplicator/

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you enter is private which means only you and I have access to it.

NOTE: If access to the live site is not possible and the staging site does not exist please provide me with a duplicator package created with the duplicator plugin.

Thank you,
Bobby

July 29, 2020 at 10:59 pm #6703583

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for the duplicator package, however, I am not able to install it without the installer.php file.

Are you by any chance using the plugin Sticky Links?

Since the issue persists with WPML String Translation deactivated, I wonder if there is a possible 301 redirect?

Is it possible to change the URL for /tools/resize/ ? I wonder what your results are if you make a small change in the permalink

July 29, 2020 at 11:10 pm #6703587

christopheP-3

Sorry Here are all the files from Duplicator: hidden link

I am not using sticky links at all and have no 301 redirects.

I just tried to changed the name of the directory tools/ to see what happens but it still does the same. I have 2 other posts with links to the directory and they do not redirect. I'm a little lost to be honest. It only happens if WPML is enabled.
If you give me your ip I can give you the admin link at least so you can see what it does. The site is behind am ip whitelist.

July 30, 2020 at 12:11 am #6703667

christopheP-3

Ok your IP is whitelisted now.
[removed]
The page with issue is: hidden link
Another page where there's a link to that directory that works is: hidden link
WPML is disabled for now. When you'll enable it you'll see what it does. I can't see where it is at all.
Thank you for your help.

July 30, 2020 at 6:37 pm #6711027

christopheP-3

Ok here's what i tried:
- Renaming the /tools/ directory: fail
- Renaming the permalink to the post: fail
- Creating a test post: worked
- Tried to recreate a new post, changing the permalink with the same content: fail
I didn't try to rename the feature image but I have a feeling that could be it. But it would have been too complicated to figure out where I used it etc. Anyway what worked is:
- Instead of the link: streamatehelp.com/tools/resize/ I linked to streamatehelp.com/tools/resize/index.html and it worked. Not sure why but it did :/

July 30, 2020 at 7:41 pm #6711237

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for updating me and the access!

Indeed, adding index.html at the end of the link works, as well as change /tools/resize/ to tools/resizeme/ for example.

I believe the issue here is the word resize, WP and WPML most likely believe it should be pointing within this page.

Another option that would allow you to keep the structure of the permalink is to add

class="wpml-ls-link"

within the a href

<a href="<em><u>hidden link</u></em>" class="wpml-ls-link">CLICK HERE TO TEST</a>

However, i dont believe this will work within the page builder button.

The topic ‘[Closed] Url button changes when WPML is active’ is closed to new replies.