Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.05 hours from now. Thank you for your understanding.

This topic contains 3 replies, has 2 voices.

Last updated by Bigul 3 years, 6 months ago.

Assigned support staff: Bigul.

Author Posts
January 16, 2017 at 1:47 pm #1183011

Tushar

I am trying to: Connect/assign a translation of a post with the equivalent in a different language.

URL of (my) website where problem appears: hidden link

I expected to see: The English post be connected to the Spanish version.

Instead, I got: Instead I get an error message, see attached image and the post does not get assigned.

Steps to duplicate the issue:

The overall problem we are experiencing is: we create our posts in Spanish and English as drafts. When we hit publish, the English version moves to the Spanish side and has it's language set to Spanish without any translations? This error message is perhaps part of the root problem, or perhaps just a symptom of an underlying problem. Either way, it's a place to start. So this ticket is specifically how we try to fix the post after it has jumped to Spanish. We switch the language of the post back to English and try to "connect with translations" from the language box on the edit post page. This is where the error occurs.

January 16, 2017 at 2:01 pm #1183026

Tushar

And when I look at the original Spanish version of the post, the Language box contains the same error, see screenshot.

January 16, 2017 at 2:07 pm #1183034

Tushar

And when I click to edit the English translation from the Spanish language box it tries to edit a content type that is not really a content type. See screenshot 'content-post-type-ccpurge'.

January 17, 2017 at 9:21 am #1183619

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for contacting the WPML support. We are happy to help you.

Please let me know the following for tracking the issue.

1) Does it happen after recent upgrade or modifications

2) Is it happening for a custom post type posts or default posts

3) Are you using a custom theme?

4) Please add the following code in wp-config.php file of your site to enable WordPress to debug mode. It will create a *debug.log* file in *wp-content* folder. Repeat the steps and check you are getting any errors or warnings related to WPML in the log file.

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
 
// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

Please check following links to read more about debugging with WordPress.

https://codex.wordpress.org/Debugging_in_WordPress

https://codex.wordpress.org/Debugging_in_WordPress#Example_wp-config.php_for_Debugging

--
With Regards

Bigul

The topic ‘[Closed] URL cache error when connecting post with Translation’ is closed to new replies.