Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 3 voices.

Last updated by Shekhar Bhandari 1 year, 4 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 31, 2020 at 12:44 pm #6259873

Timothy

I'm trying to have a different language other than English on the URL link.

hidden link

It gives me a 400 error. I changed the collation within the mysql database already but still not working. Updated the Permalink as well.

I'm currently using Netfirms Hosting Package.

June 1, 2020 at 12:18 pm #6265301

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

While you are waiting for one of my colleagues to take this ticket and work on it, let me provide you with first debugging steps or if I can perhaps help with the issue quickly.

Can you tell me if the issue is happening even if you deactivate WPML, but you try to access any URL such as hidden link your website?

Because if yes, then you will need to see with your hosting company, as I see that it returns error 400:
hidden link

But as an alternative, if your server is unable to process these requests, I suggest you choose any of these options in WPML so that you could translate these URLs yourself. For the already translated pages, you can edit their slugs like this:
hidden link

Regards,
Bruno Kos

here.jpg
June 4, 2020 at 8:09 pm #6298545

Timothy

I still need help. Hosting is with Netfirms does anyone encounter this problem?

June 5, 2020 at 4:23 am #6300767

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I'd help you further with this issue.

Can you tell me if the issue is happening even if you deactivate WPML, but you try to access any URL such as <em><u>hidden link</u></em> your website?

Can you provide feedback on this?

Further, we recently released a new version of WPML plugins so can you please update the plugins to the latest version and let me know if that helps.

We push out WPML releases gradually. If your sites haven’t received this update yet, give it some time and you’ll see the update in a few days.

To skip the queue and get the update right away, to the Plugins → Add New page, click the Commercial tab and then click the Check for updates button.
https://wpml.org/wp-content/uploads/2020/04/wpml-force-plugin-update-1.png

Note: Keep a Backup Before Updating

Look forward to your reply.

Thanks

June 12, 2020 at 2:25 am #6355293

Timothy

Hi. we updated the plugin. Tried the link with and without the wpml plugin but still getting the same problem of 400 bad request.

June 12, 2020 at 3:18 am #6355721

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To further debug this issue, To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

The topic ‘[Closed] URL Link with language within URL is not working’ is closed to new replies.