Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by bjornT-7 6 months, 2 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
April 28, 2019 at 8:44 am

bjornT-7

Hello,

Had this issue before, and it was solved by a support-guy from WPML, but it keeps showing up.
In my product-page (Turbo Theme) the URL of the products in English don't show the language-code, so it redirects to the Dutch page of the product.

This is an issue:
Different languages in directories ((hidden link - Dutch, hidden link - English))

This works fine:
Language name added as a parameter (hidden link - English)

Also after re-saving permalinks, it makes no difference.
Of course I want to use the first option, it's cleaner than "?lang=en".

Thanks in advance for taking a look at this.

April 29, 2019 at 3:19 pm #3704885

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @bjornt-7, welcome to the WPML support Forum!

We released a new version of WCML today (4.6.2.1). Could you please update and check if the issue persist?

if the issue still occurs, could you please send us a link of the product with the wrong URL?

Please let me know if it worked for you.

All the best,
Diego

April 29, 2019 at 3:38 pm #3705091

bjornT-7

Hello Diego,

Problem still present after update.
Every product on this page gives the wrong link...
hidden link
Previously it worked fine, you're college fixed it once, but it came back.

April 30, 2019 at 1:16 pm #3711343

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. I checked your website and it seems that your website is using "Different domains per language", which means in this case:
- hidden link - Dutch
- hidden link English
- hidden link (ensligh product page)

When using different domains per language, the language directory is not needed, so it works as expected. The only issue I found is a error with the SSL certificate (see screenshot).

Do you need to revert the settings to "language in directories" (and not different domains per language)? Or just fix the SSL error?

Kind regards,
Diego

April 30, 2019 at 1:19 pm #3711369

bjornT-7

Hello Diego,

Yes, after I've posted my previous message, I tried other stuff, like the domains.
The SSL will be fixed.
Now, I think language per domainname will be better for us, but now I have a second problem...
Is it possible to assign 2 languages to one domainname?
Because...
.nl is only Dutch
.fr is only French
.be can be Dutch or French...
Is that even possible?

May 1, 2019 at 4:33 pm #3718925

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Unfortunately WPML does not have this feature at the moment. It's possible to assign only 1 domain per language.

It's may be possible to configure that in your web server (or using .htaccess). You can find an example per the following StackOverflow answer: http://stackoverflow.com/a/10241757/344930
https://stackoverflow.com/questions/10232722/htaccess-rewrite-based-on-hostname-or-domain-name/10241757#10241757 - However, since it is not a feature of WPML, it escapes our scope of support.

You would need to ask your system administrator or a programmer to edit those rules for you. If you need, we have a list of experienced contractors available here: https://wpml.org/contractors/

If you need more help just let me know.

Kind regards,
Diego

May 5, 2019 at 7:12 am #3741917

bjornT-7

My issue is resolved now. Thank you!