This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Lauren 7 months ago.

Assigned support staff: Lauren.

Author Posts
March 21, 2019 at 3:33 pm #3410099

briceB-3

I am trying to: traduce a caldera form. The traduction is OK But I have a problem with the url. The error message is : Submission URL and current URL protocols do not match. Form may not function properly.

Link to a page where the issue can be seen: hidden link

March 21, 2019 at 8:14 pm #3421131

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I no longer have the credentials on the previous ticket - could you share them here so I can log in and take a look at this form? Thanks! The next reply is marked as private.

March 22, 2019 at 4:51 am #3437497

briceB-3

Hello, sorry but this message is not private. Can you resend me please in order to send you the credentials

March 22, 2019 at 3:12 pm #3441703

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The next reply is private, you may need to refresh your page in order to see the private fields. Thanks!

March 22, 2019 at 3:49 pm #3442061

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please try disabling temporarily the WordPress HTTPS plugin. Does the message still display with this plugin deactivated?

March 22, 2019 at 3:56 pm #3442091

briceB-3

Hello, when I deactivate it, the message doesn't appear. But I don't know why, when I click on the link to this pages, I see that hidden link is charging but it's the French pages that appear.

March 22, 2019 at 4:16 pm #3442209

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I'm not sure where you are getting that link from, but the correct link for the form is hidden link

Here, I see the form in English and no message. Since the message does not display when HTTPS is disabled, I don't think it is an issue with Caldera forms and WPML. I think there is an issue with your HTTPS plugin not working on translated form.

Please let me know if you need any further assistance and I will be happy to help.

March 22, 2019 at 4:47 pm #3442547

briceB-3

Normally, when I'm on this page hidden link, and I click on "Mon profil" (see print screen), the french profile page should appear. But not, it's always the english version. Same problem with this pages hidden link. When I'm on it and I click on request a special course, the french version of the form appear instead of the english.
It's the only two pages when I have this problem.

March 22, 2019 at 6:29 pm #3443489

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

As the original issue is resolved may I kindly ask you please to open a new ticket for this question?
This will help other users with similar problems find solutions when searching the forum as well as avoid mixing lots of questions in one ticket. There are a few settings that might help you when you open the new ticket. I'm not sure how those buttons are added to the top of the profile page, but if the URL was set manually, it will need to be updated to the correct URL format (directories instead of parameters). Also, for the profile link, if that is a custom link in the menu, it will need to be translated to link to the French page. I tried to check these settings for you, but your site keeps returning a server error.

Checking these first will help troubleshoot in the new ticket. Thank you for your understanding.

March 22, 2019 at 7:55 pm #3444027

briceB-3

Hello OK. And what can I do with the problem of the https compatibility ?

March 22, 2019 at 8:35 pm #3444157

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would contact the authors of the HTTPS plugin and ask if there is a setting for subdomains or domain directories that can be used to resolve the error.

March 23, 2019 at 7:26 am #3445693

briceB-3

OK thank you very much. Take me inform.

March 25, 2019 at 12:24 pm #3453459

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Great, thanks for the update.