Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by lukaszP-11 1 year, 7 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 18, 2019 at 2:43 pm #3370299

lukaszP-11

I am trying to set "Language URL format" to "Different languages in directories" but I receive the message:
"It looks like languages per directories will not function. Details
This can be a result of either:
WordPress is installed in a directory (not root) and you're using default links.
URL rewriting is not enabled in your web server.
The web server cannot write to the .htaccess file"

I've tried the solution described here:
https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/
htaccess file contains code given in your solution
and hidden link
call returns
<!--hidden link;

Server admin claims that on server side everything is OK (URL rewriting is enabled on web server)

What else can I do?
I found on your forum, that htaccess should have "777" file permission, but is it safe solution?

Regards

March 18, 2019 at 7:01 pm #3372579

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. The language in directories settings list some possible reasons when this setup is not working properly. The reasons are:

1 - WordPress is installed in a subdirectory inside the host server root directory.

2 - URL rewriting is not enabled in your server.

3 - Your .htaccess file is not writable.

In the case of your .htaccess file you can make sure it has the proper write permission changing your permalink structure and clicking to save it from your WordPress Dashboard > Settings > Permalinks, try the 'Post name' choice from the list of available options and let us know if you see any message regarding your .htaccess permission.

See: https://codex.wordpress.org/Using_Permalinks

Please, let me know the results. Have a nice day.

March 19, 2019 at 8:45 am #3376453

lukaszP-11

Hello,

ad. 1
WP is installed in main "public_html" folder for gis-expert.pl domain. What do you mean by "host server root"?

ad. 2 Yes, URL rewriting is enabled on our server.

ad. 3 We've changed Permalinks setting to "Post name" but nothing's happened. The message in WPML menu is still the same. We also changed manually chmod for htaccess file from 644 to 777 for a moment, but it didn't worked.

Regards

March 19, 2019 at 5:07 pm #3381871

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the confirmation. I mean the host root folder when I said 'host server root' in most cases the public_html folder. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

March 21, 2019 at 9:51 pm #3425127

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. I took a detailed look in your WordPress Dashboard and your .htaccess file, although it has the proper permission now, I see a lot of additional rules added for some plugins of your WordPress install which could be the reason of such issue. Please, try the following:

1 - Disable all the plugins of your website in your WordPress Dashboard > Plugins, except the WPML related ones.

2 - Take a look in your .htaccess file and make sure only the default rules added by the WordPress Dashboard > Settings > Permalinks save action for the 'Post name' choice is present in your .htaccess file, as the below:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

3 - Try your translated homepage again (hidden link).

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if it helps, have a nice day.

April 2, 2019 at 8:19 am #3514679

lukaszP-11

My issue is resolved now. Thank you!