Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 3 voices.

Last updated by calvinY-3 4 weeks, 1 day ago.

Assigned support staff: Christopher Amirian.

Author Posts
January 13, 2021 at 5:35 pm #7837885

calvinY-3

My site have 3 languages, on some pages they have the same url string only with different language short form, e.g.

CHI: hidden link
ENG: hidden link

it works fine for the base url, however change the page number on a language e.g.

hidden link and switch language, it got reset back to
hidden link
instead of
hidden link

January 13, 2021 at 7:37 pm #7838595

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello, welcome to the WPML support Forum!

Before your ticket is assigned to one of my colleagues, please allow me to walk you through some initial debugging steps. This will help speed up the support process.

Are you using DIVI? If so, please try the following solution: https://wpml.org/forums/topic/blog-pagination-not-working/#post-5002643

Please also regenerate your permalink structure and check if the issue persist:
- Go to Settings > Permalinks
- Click on Save

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE:
Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

Please let us know if it worked for you.

January 13, 2021 at 8:18 pm #7838815

calvinY-3

No, i am not using DIVI, tried both methods still not working

January 14, 2021 at 6:39 am #7840951

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Thank you for the information. It might be the fact that it is a problem of compatibility with the theme that you use.

To test that I suggest that you do the following steps:

- Go to WordPress Dashboard > WPML > Languages.
- Enable the footer language switcher.

- Go to "WordPress Dashboard > WPML > Languages > Language URL Format".
- Check the "Language name added as a parameter" checkbox. (Temporarily it is just a test)
- Click the "Save" button.
- Go to "WordPress Dashboard > Settings > Permalinks".
- Make sure that the "Post Name" option is selected.
- Click the "Save" button to flush the permalinks cache.

- Create a backup of your website. You can use backup tools from WordPress: https://wordpress.org/plugins/tags/backup/
- Switch to a default theme such as "TwentyTwenty" by going to "WordPress Dashboard > Appearance > themes".
- See if the issue is fixed.

Kindly get back to us with the result of the tests above.

Thank you 🙂

January 17, 2021 at 8:42 am #7861847

calvinY-3

No it doesn't, you can see from here:

hidden link

if i change language to english it goes back to hidden link which is page 1 of English

January 17, 2021 at 1:52 pm #7862881

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Thank you for your answer. I did a research and it might be a compatibility issue with the theme that you are using.

From what I understand the properties are part of that theme.

To see if it is a compatibility issue or not, I created a clean installation of WordPress, WPML, and all necessary WPML add-ons.
You can access the WordPress dashboard using the link below:
hidden link

Kindly follow the steps below:

- Install your theme.
- Install the necessary plugins for the theme.
- Add a few sample properties and translate them.
- Go to Settings > Reading and make sure that the per-page post items are set to 2 so that it will trigger the pagination.
- Try to replicate the issue.

This will help us to report the probable issue to the compatibility team and solve the possible problem faster.

Thank you.

January 17, 2021 at 3:09 pm #7863319

calvinY-3

Done, behave exactly the same,

hidden link select chinese
it will return to hidden link

so there is nothing I can do except talk to the theme creator?

January 18, 2021 at 12:18 pm #7868499

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

For some reason, the installation that I created shows an error and I can not access the website:

hidden link

As the theme developer claims that they are compatible with WPML, this is something that the theme developer needs to follow up on. We do not have the theme listed as a compatible one.

If the theme developer is interested in having their theme listed they are welcomed to join our go-global proram:

https://wpml.org/documentation/theme-compatibility/go-global-program/

If you are interested, we can also report this to our compatibility team. There will be no guarantee for a fix but they can take a look into the matter and they might find a clue.

For that, we need to have a clean installation of the theme. As the one I created has errors I created another one and I'd appreciate it if you could follow the same steps I mentioned in the previous answer so that we can have the website working correctly to create the compatibility ticket.

hidden link

Thank you.

January 18, 2021 at 2:07 pm #7870031

calvinY-3

I have install only the theme, and i can see it with this url: hidden link

please help me report to your compatibility team, while i contact the theme creator (which is quite hard to reach)

January 19, 2021 at 1:12 pm #7878183

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Thank you for replicating the issue on a clean installation. I reported this to the compatibility team.

Please kindly consider that as this theme is not listed as the compatible theme on our side there is no guarantee for a fix and along the way we may need the cooperation of the theme developer.

I'd appreciate it that you share the same clean installation with the theme developer as they know their code better and they might have insight on a fix.

We will update you here if there is a workaround.

Thank you.

January 21, 2021 at 2:46 pm #7897997

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

I have an update from the compatibility team. It seems that the behavior is for all the post type pagination and not related to the theme in question.

Unfortunately, it is not possible to link to the paginated version of the Translated or the Original language and our compatibility team gave good reasoning:

Suppose you have 100 posts in English, and only 5 of them are translated into another language.
Suppose also that pagination shows 5 posts per page and you are looking at the second page in English.
You change language and expect to see the second page, but in that language, you can only see one page because, again, there are only 5 posts.

So basically, it is not possible to predict if enough posts are translated to make sure it is linked to the exact pagination, and the pagination count may differ between the original and translated languages.

That is why it is not possible to implement such a feature due to that paradox.

Thank you for your understanding.

January 25, 2021 at 2:58 pm #7922865

calvinY-3

so basically this is either how wordpress structure or how WPML approach to do translation make them impossible, which make organize contents very difficult

January 26, 2021 at 7:04 am #7927745

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

As mentioned in the previous reply, there are case scenarios that it is not possible to have a one to one equivalence of the pagination between the original and translated posts, that is why it is not possible to have the feature that you asked for.

It is not a matter of WPML or WordPress setup, it is a matter of a use case that is not possible to implement because of the error in the logic. For example, if you have 20 pages and you translate 10 of them, and you set the pagination for 10 items, the original language will have pagination to the second page, but the translation will not as it has only 10 items.

I hope I could explain the case correctly.

Thank you for your understanding.

January 26, 2021 at 4:15 pm #7933821

calvinY-3

i understand the logic, i have another plugins called post type order which allow WPML sync post order, when it encountered the problem you mentioned, it will give warning saying the post number are not the same, however when they are the same, the sync can be done.

this logic error only happens how wordpress or WPML structure to the contents, for example, if the translation logic is structured per-post, when you have 3 languages, all 3 languages must exist of the same post, not allowing different languages have different numbers of post.

anyway i understand why it cannot be done (apart from it can be done), but it will be too much of changes to make it works so i accept the situation.

January 26, 2021 at 4:16 pm #7933823

calvinY-3

My issue is resolved now. Thank you!