This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by Mihai Apetrei 2 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
August 14, 2019 at 5:57 am #4392535

aliY-5

I am trying to:
i want the urls of my site to work only with /ar/ but it works with it and without
Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

August 14, 2019 at 9:57 am #4393927

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I think what you need is to go to WPML > Languages and select the "Use directory for default language" checkbox, then Save.

I am also attaching a screenshot as an example.

Kind regards,
Mihai Apetrei

August 14, 2019 at 11:41 am #4394535

aliY-5

this option is activated but i still can visit both links

August 14, 2019 at 11:54 am #4394619

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Thank you for letting me know.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 14, 2019 at 9:27 pm #4397679

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they worked and I was able to log in.

When I go to WPML > Languages (hidden link), I see the errors in the screenshot below.

That might be the reason why that doesn't work.

Can you please analyze the errors there try to see which ones of them are applicable to the current situation?

Please let me know what you are able to find.

If you still need help, I will be more than happy to look it out for you, but I will need your written approval to also enable/disable plugins so please create a full backup of the site before that.

I will be waiting for your response.

Kind regards,
Mihai

August 15, 2019 at 2:14 am #4398273

aliY-5

what code do u need to add it in .htaccess file

August 16, 2019 at 1:15 am #4403881

aliY-5

?????

August 16, 2019 at 9:06 am #4405549

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and sorry for the delayed response.

I did not work yesterday.

Regarding your question, I did not say that there's something that needs to be added to the .htaccess file, I just said that there are a lot of hints there, written in red, and I can't know for sure which one of them is the one that we need to implement, until I don't take a deeper look (but for that I will need your written approval).

However, I wanted to leave you the option to check the errors on your own, if you preferred that.

Please let me know if you are ok with me investigating deeper on this (if you want this, I will also need you to please check the SFTP/FTP credentials once again as they don't work for me to log in - can you also please let me know what port should I use?).

Thank you and I will be waiting for your response.

PS: Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

August 16, 2019 at 6:43 pm #4407865

aliY-5

nvm i requested refund

August 19, 2019 at 4:42 pm #4417505

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

I understand.

I am very sorry to hear that and I wish that I was able to help you forward with this.

Going forward, can you also please confirm that it is ok for you if I will close this ticket?

I will be waiting for your response.

Kind regards,
Mihai

The topic ‘[Closed] url working both with /ar/ and without for same topic’ is closed to new replies.