Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.71 hours from now. Thank you for your understanding.

This topic contains 24 replies, has 2 voices.

Last updated by Andreas W. 1 year, 1 month ago.

Assigned support staff: Andreas W..

Author Posts
June 25, 2019 at 2:38 pm #4085553

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sadly not a SEO specialist but search bots do not crawl false URLs. Further, a redirection in sense of SEO is not recognized as duplicated content.

There is a plugin that disables the WP URL autocorrect guessing.

https://wordpress.org/plugins/disable-url-autocorrect-guessing/

I have installed it on the sandbox test site and it hooks into the WordPress Core and disables the function. this will also include any URL created by plugins used on the site.

I hope this answers your questions.

Kind regards
Andreas

June 27, 2019 at 1:39 am #4095483

karenK-9

It's very confusing, but I cant do anything about it.
I have one last question.

Is there a quick way to translate the title but keep the original slug?

For example my original page:
Title - Test Page
Slug - /test-page/

when I translate it:
Title - Test Page German, Russian, Armenian, Georgian
Slug - /ge/test-page/

Thanks

June 27, 2019 at 6:46 pm #4102189

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Indeed, it is possible to edit any slug for posts, pages and custom post types on the WordPress Editor. This slug usuallz is set by default to page title, but you can edit it afterwards.

More information here:

hidden link

Let me know if this answered your question.

Kind regards
Andreas

June 27, 2019 at 8:56 pm #4102981

karenK-9

I understood that I can edit it after however it is NOT convenient at all. If I translate the titles as well than I can't find the correct ones to translate back as I don't speak a translated language.

My question is still open. Is there a way to translate a page and at that moment change the title and keep the slug?

June 28, 2019 at 2:55 pm #4108819

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The WPML Settings do provide options for such cases.

Go to WPML -> Settings -> Translated documents options -> Page URL.

As mentioned earlier by default the title generates the slug. Further, options are to translate (this will include the slug in the translation and not create it automatically from the title) or to Copy from original language if translation language uses encoded URLs.

Could you please test these options and let me know if this solves the issue?

Kind regards
Andreas

June 28, 2019 at 5:40 pm #4109719

karenK-9

Thank you!
As far as I understood I need to use the 1st option "Translate ....."

thanks

June 28, 2019 at 6:11 pm #4109837

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Yes, actually it is the second option, but the first option after the default setting: "Translate (this will include the slug in the translation and not create it automatically from the title)"

Please let me know if you experienced any unexpected issues.

Kind regards
Andreas

June 28, 2019 at 9:24 pm #4110221

karenK-9

It's me again with and again your plugin drives me crazy.

1. I cannot enable this option hidden link

2. What should I do with this hidden link

3. How to get rid of this hidden link so when I finally enable #1 issue I can keep slugs.

Thanks

June 28, 2019 at 10:30 pm #4110265

karenK-9

I resolved most of the issues, however, i cancelled the translation job to disable In Process status (issue #3) I don't see slag field which I enabled on issue #1. It only appears on all pages

June 28, 2019 at 11:49 pm #4110293

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

The topic ‘[Closed] URLs issues’ is closed to new replies.