This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by gaudi-audio-labG 2 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 8, 2019 at 2:11 am #4358867

gaudi-audio-labG

I am trying to: Add language switcher at the header and make to work correctly.

Link to a page where the issue can be seen: hidden link

I expected to see: Can go the English site (en.gaudiolab.com) to the Korean site (kr.gaudiolab.com)

Instead, I got: In the language switcher, the URL of the Korean site is the URL of the English website.

August 8, 2019 at 6:09 am #4359929

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

Seeing the source code it seems the language switcher is customized by the theme or custom coded and hence it is missing the correct link to the translated pages. Can you please clarify whether any customization added to the language switcher if so can you please point to us the exact code or location where the custom code is added.

I would also request temporary access to your site. it will enable me to check for a few parameters on your site dashboard. I have enabled private fields for you to securely share the details.

Kind regards
Raja

August 12, 2019 at 12:34 pm #4380749

gaudi-audio-labG

I resolved this issue by replacing language switcher to custom link.

August 12, 2019 at 12:35 pm #4380751

gaudi-audio-labG

My issue is resolved now. Thank you!