This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bobby 1 year ago.

Assigned support staff: Bobby.

Author Posts
October 1, 2018 at 8:04 am #2777307

sensofar-tech-slS

Hola! Necesitaría un poco de ayuda... Por distintos motivos se ha descartado la opción de añadir como suscriptor a nuestra empresa de traducción (y tampoco está incluida entre las recomendadas que salen por defecto en WPML). Por lo que la única solución que hemos encontrado es descargar los archivos XLIFF en el "Default Language" y que los traductores nos lo entreguen en los idiomas que necesitamos también en el mismo formato, para cargarlos en la web. ¿Tenéis algún manual/tutorial dónde explique como realizar este proceso y los problemas (o no) que se puedan derivar de él? ¡Muchas gracias!

October 2, 2018 at 5:43 pm #2782426

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please review the following documentation and let me know if this helps or if you have any further questions regarding the process.

https://wpml.org/documentation/translating-your-contents/using-desktop-cat-tools/

https://wpml.org/documentation/translating-your-contents/using-desktop-cat-tools/configuring-xliff-file-options/

https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

October 3, 2018 at 9:47 am #2784093

sensofar-tech-slS

Hello Bobby,

Thank you for your answer.
We've followed what this link said: https://wpml.org/documentation/translating-your-contents/using-desktop-cat-tools/configuring-xliff-file-options/
Our procedure it is Manually downloading the XLIFF Files, as it says there.
But our problem it is that we've previously translated from English to Chinese (some months ago) and now that we have translated from English to Japanese (same contents), any time we upload those translation files, they overlap Chinese position. So we get Japanese translations in Chinese site.
Do you know why this happens?

(I've attached you an code example of one of those translations)

October 3, 2018 at 9:06 pm #2785751

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

to make sure i understand correctly.

you want to translate from English to Japanese , then download the XLIFF (this is working as expected) then add your translations and return completed translation by uploading it back as shown here https://wpml.org/documentation/translating-your-contents/using-desktop-cat-tools/configuring-xliff-file-options/#returning-completed-translation

when you view the translations of the page now you see Chinese content instead of Japanese ?

are you uploading individual files or multiple files ?

October 4, 2018 at 10:15 am #2787135

sensofar-tech-slS

Hello,

No, when I check translations in the page I see Japanese instead of Chinese (so, I switch to chinese and I get Japanese... Chinese language has disappeared)
We download several files but we've just upload one single file as a "trial"...

October 4, 2018 at 5:58 pm #2788495

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If possible i would like to take a closer look.

please provide me with the page that you did the test already and also if you have another xliff file i would like to test uploading it as well

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

The topic ‘[Closed] Use our own translation company (not as suscriptor), using XLIFF files’ is closed to new replies.