This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: My Account page doesn't show in the trasnaltion.

Solution: Goto WPML > Settings > Post type translation, Change the option for the "PAGE" post type to "Translatable - use translation if available or fallback to default language"

This topic contains 27 replies, has 2 voices.

Last updated by ahmedM-19 4 weeks, 1 day ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 13, 2019 at 4:46 am #3603541

ahmedM-19

Is there any updates on translating "my account page" !!!

April 14, 2019 at 3:21 am #3606367

ahmedM-19

Hi Raja,

The existed page now is the English one not Arabic.

Thanks
Dodd

April 15, 2019 at 5:48 am #3609821

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Kindly apologize for the miscommunication,

The remaining test should be translated from String translation, if it does not reflect on the front end either it should be an issue with cache or the server PHP input vars is not sufficient.

It seems there is some issue with the server, I have tried to access the user account page it's giving me 504 error. can you please verify the same. I'm using the login provided by you.

504 error might be due execution time exceeded try increasing the max_execution_time.

Kind regards
Raja

April 16, 2019 at 5:09 am #3618259

ahmedM-19

Hi Raja,

Tell me what you you want to do and I will do it because I have no problem to access any pages... which remaining test you mean!!!

Thank you
Dodd

April 16, 2019 at 8:35 am #3619755

ahmedM-19

This is my host provider reply:
.......Currently the website is up and running but the error (Gateway Timeout) you were facing is most commonly related to the high CPU usage 5889.76/4000 caused by plugin.......

When I tested plugins, I found that WPML is the reason for this.

April 16, 2019 at 12:27 pm #3622035

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Dodd,

I'm still having an issue accessing the user account. I'm troubleshooting the performance issues with WPML plugin. I will update you with the results soon.

Kind regards
Raja

April 16, 2019 at 12:56 pm #3622187

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI Dodd,

I am obtaining duplicator package of your site to check the issue locally. I will update you with my findings soon

Regards
Raja

April 17, 2019 at 7:13 am #3627623

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Dodd,

Thanks for your patience. The issue seems to be related to WPML cache. Please follow the steps.

Make sure you have disabled your site cache and server cache

1) Goto WPML > String translation > Troubleshooting (check attached screenshot)

2) Click on the following buttons in the troubleshooting page
- Clear the cache in WPML
- Recreate ST DB cache table

3) Goto WPML > String translation search for the strings to translate. Add a minor modification to the translation and save.

This should fix the issue, let me know the results.

As far I see the account page should work when the page is translated, Can you please report this to the theme authors, the last time the theme checked for compatibility is almost 5 months back.

I have also tested the slow response issue after disabling all plugins and WPML the site seems to be responding slowly with the only theme and theme related plugin. Please check if the CPU usage is happening when you disabled WPML plugin (this won't cause any data loss).

If the issue still persists I will clone your site to our private server for live testing.

Let me know the results, please.

Kind regards
Raja

April 17, 2019 at 2:53 pm #3632135

ahmedM-19

Hi Raja... Thank you for your response.

I followed your steps in the support section of WPML:
- Clear the cache in WPML
- Recreate ST DB cache table

What do you mean exactly by""Add a minor modification to the translation and save.""

Thank you
Dodd

April 18, 2019 at 8:21 am #3637221

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI Dodd,

What I meant is if you already translated the strings Please delete the last letter and add it again so that your string will be saved as a new update.

I hope it's clear now. Let me know if you need any clarification.

Kind regards
Raja

April 20, 2019 at 4:58 am #3649519

ahmedM-19

Hi Raja,

The theme support says:
We have tested the theme with WPML and it is fully compatible. Please ask them for specific issues so I can update it to my development team.

Thank you for your support.

April 22, 2019 at 4:01 am #3653879

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Dodd,

We have reproduced the issue related to the user account page. The user account translation page is not displaying when the translation rule for the page is set to
"Translatable - only show translated items" in WPML > Settings > Post Types Translation.

However, the user accounts work fine when the translation rule is set to "Translate - Fallback to default" and the page is not translated. I'm not sure if that is expected behavior please check with the theme support.

We have a sandbox site where the issue can be seen :

Original: hidden link
Translated: hidden link

One click login => hidden link

I hope this helps you better. I have noticed my colleague Andrew is doing excellent work in this thread https://wpml.org/forums/topic/translating-contents-2/ to help you resolve the string translation issue. Please follow up with him.

Kind regards
Raja

April 24, 2019 at 11:04 am #3671869

ahmedM-19

My issue is still not resolved . Thank you!