This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 3 voices.

Last updated by Shekhar Bhandari 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 6, 2019 at 12:16 pm

abdul-alimB

We created duplicate users for Arabic (since WPML doesn't translate users)
Now, the error we are facing is that: users get redirected to default to default language - English. As a result of that, the Arabic contact form is not loading, and texts are showing on left instead of right side (Arabic texts are right aligned)

We deleted cache etc, but it doesn't seem to help. Kindly check and help with it.

Link to a page where the issue can be seen:
hidden link

May 6, 2019 at 6:41 pm #3752133

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please let me know the exact steps to reproduce the issue on your site. Because not able to replicate it exactly.

The login is also not working because of the following error. Please check it.

ERROR: The username or password you entered is incorrect

--
Thanks!

Bigul

May 7, 2019 at 4:51 am
May 7, 2019 at 3:10 pm #3759609

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. But sorry, still I am not able to login to the site because of wrong user name or password. Please check.

Also please share a couple of screentshots for a better understanding of the issue.

--
Thanks!

Bigul

May 8, 2019 at 6:50 am
May 8, 2019 at 1:08 pm #3766981

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, I am still not able to log in the site because of ERROR: The username or password you entered is incorrect error. My colleagues also getting similar results.

Now Wordfence has blocked me after a few failure logins attempts. Please check the attached image for more details and clear my blocking.

--
Thanks!

Bigul

May 9, 2019 at 7:13 am #3773583

abdul-alimB

Dear Bigul,

Could you please provide me your email Id? I will mail you the login credentials.
I am surprised why the credentials are not working at your end!

May 9, 2019 at 12:20 pm
May 13, 2019 at 5:51 am #3795281

abdul-alimB

Dear Bigul,

Thanks a lot for sharing your email. I have just mailed you the credential. Hope you dont have any issue logging in.

My sincere apologies for the trouble. Don't know why the credentials didnt work at your end even after I checked here to be working.

May 14, 2019 at 4:41 am #3803607

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello Abdul,

Since Bigul currently has a few days off, I will replace him here in the forum. I hope this is OK for you 🙂

Bigul has forwarded the email with the login details, so using that details I am able to login to your site.

The language you have selected from his profile page is only for dashboard languages (i.e. when the user will be logged into the site dashboard the admin language will be Arabic)

The selected language doesn't have any effects on the front-end.

Also, since the page hidden link language is English, The contact form is displayed as English.

If you want to display the contact form based on the language selected on the profile, you will need to write some custom code to make it work, which is beyond the scope of our support.

At this point, I would suggest you consider contacting one of our certified partners from this link: http://wpml.org/documentation/support/wpml-contractors/

Before doing so please have a look also here:
http://wpml.org/documentation/support/wpml-contractors/guidelines-for-people-looking-for-consulting-help/

You will get the custom assistance you need to get on with your project.

Thanks

May 15, 2019 at 5:40 am #3812357

abdul-alimB

Dear Shekhar,

Thanks for your response.
However, I am not fully convinced with your statement that 'selected language does not have effect on front-end'. Because, until I installed the last updates of WPML,pages where I selected Arabic were considered as Arabic pages and arabic contact form was loading on them. Texts were aligned on right side.

Even now, you can see that only Arabic doctor profiles are getting picked when I do a search query in Arabic subdomain.

hidden link

Hence, please take a relook and see why the page is loading as English when Arabic is selected as language. It didn't do that before.

May 15, 2019 at 6:06 am #3812447

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I think you misunderstand here, I mentioned: "The selected language from the profile doesn't have any effects on the front-end."

Regarding the contact form issue, could you please let me know how it's added? I can see contact form loading correctly on this page hidden link

But on the single user page, it's not loading properly.

Also, regarding the content, it all started after the latest version? Does it look like the content is mixed? or are the translation not completed yet?

Look forward to your reply.

Thanks

May 15, 2019 at 6:25 am #3812471

abdul-alimB

Dear Shekhar,

Please click on any of the doctor profiles in the link you shared above. You will see that the doctor profiles are loading under subdirectory gingerhealthcare.org/ar and the page is loading in Arabic, and contact form is also loading in Arabic. (see attachments)

The fact that it is loading under subdirectory /ar means that selection of arabic language on profile page is working.

However, something happens (cache or what I dont know) that takes the profile from under subdirectory to main domain and then the page loads in English.

Hope you understand the concern.

May 15, 2019 at 10:21 am #3814863

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I clicked a few doctors links and it's not being redirected to the default language.

Am I correct to say we have 2 issues here?
- Doctor profile link redirecting to the default language
- Contact form not loading according to the selected language?

Regarding the contact form issue, could you please let me know how it's added?

Thanks

May 15, 2019 at 10:40 am #3815033

abdul-alimB

Dear Shekhar,

You got it right. The main issue is that, doctor profile is redirecting to default language (English) even when the language is mentioned as Arabic.

If you look at the profiles, you will see that they load on both root directory and sub-directory.
hidden link
hidden link

Probably all we need to do is just ensure that profiles which have Arabic as language should load only on subdirectory (first option above). If that happens, contact form issue will be taken care of automatically, as that loads the right (arabic) contact form.

*Honestly, I dont know how the contact form loads on profile page. It was added by developer, who is currently not available. But if you can force arabic language profiles to load only on subdirectory (/ar) as explained above, we don't have to do anything with contact form.