Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.39 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Itamar 2 years, 1 month ago.

Assigned support staff: Itamar.

Author Posts
May 28, 2018 at 10:33 pm #2242121

mikeE-8

Hello,

None of our user roles are able to edit pages/posts. When we disable "WPML Multilingual CMS" they are able to edit pages/posts. Obviously this is a serious issue. I've seen that it's been a problem for years, but I don't see resolutions. Please advise.

Thanks,

May 30, 2018 at 8:21 am #2249554

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Thank you for contacting the WPML support forum.

Is it happening also in the default language of your site or only in the translated pages and posts?
If it is only in the translations then have you added these users to be translators in WPML -> Translation Management -> Translators (tab)?
If you haven't done so and haven't added languages pairs for these translators, then they will not be able to translate your site's content.
Please read about it our documentation here.
https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/#setting-up-translators

If this is not the issue, then please elaborate further on the issue.
You write: " I've seen that it's been a problem for years, but I don't see resolutions."
Can you share with me a link to another ticket where this problem is mentioned?
Can you please explain to me the process that a user is trying to do and then get this issue?
Sometimes screen-shots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

Thanks,
Itamar.

May 30, 2018 at 3:45 pm #2252175

mikeE-8

https://wpml.org/forums/topic/user-roles-editor-cant-edit-pages-posts-only-admin-can/

this happens in the native language.
1. log in as an editor
2. click "pages" or "posts" or any custom post type
3. click "edit" under a page.
4. the page refreshes and appends this to the URL: #no_privileges

Yea, now that you mention it, the editor can't edit translated pages either. Hovering over the edit button for any languages says "you do not have permissions".

I changed the permissions to allow the editor to edit translations, but that didn't change anything.

So there are 2 issues:

The editor is still unable to edit translated pages/posts, even after granting permissions.

The editor is unable to edit native language pages/posts.

May 30, 2018 at 7:35 pm #2253146

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the extra details.

I've found out that this issue is probably related to the Toolset Access plugin that you are using. I can see in the Toolset support forum and also in our internal documentation a closely related issue. The issue will be fixed in a future version of the Access plugin, but there is a fix that is suggested for this issue. Please see this fix here.
https://toolset.com/forums/topic/no_privilege-error-when-trying-to-edit-images/
See the brief description section at the top.
Can you try to add this function to your theme's functions.php file and see if it helps?

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Meanwhile, I'm also waiting for a reply from my superiors about this issue.

Thanks,
Itamar.

May 30, 2018 at 7:48 pm #2253154

mikeE-8

I added the code to functions.php but it didn't fix either issue.

May 31, 2018 at 7:11 am #2254616

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying the fix.

Have you configured the Access plugin in any way?
Have you changed the default permissions for the Editor role?

While I wait for your reply, I'm discussing this issue with my superiors.

Thanks,
Itamar.

May 31, 2018 at 2:58 pm #2256976

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm informed by my superiors that a fix for this issue will be included in a future version of the Access plugin. But currently, I have no exact information when it will be released. A temporary fix for this issue will be provided ASAP. I'll update you here when I get it.
Meanwhile, if possible, you can deactivate the Access plugin, and the problem should be gone.

Thanks,
Itamar.

June 27, 2018 at 9:49 am #2437496

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Our second tier supporter is asking for a dump of the DataBase of your site to provide a workaround for this issue that you are having.
Can you please send a copy of your DB to us?
You can upload it to a service like Google Drive or Dropbox and share the link with me.
For this I'll enable private message for the next reply.

Thanks,
Itamar.

July 14, 2018 at 9:30 pm #2505181

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Update
This issue is solved with version of the Access plugin.

Best Regards,
Itamar.