This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to in registration window, after username and pass fields, is select option with user roles to choose. In English side is fine (User, Single agent, Agency, developer), but on Serbian side, there is nothing. I translated all strings that contains those roles, but cannot see on registration window.

Solution: The cause of this issue was that the strings you translated weren't the ones that appeared in the form. I added the necessary code in WPML -> Settings -> Custom XML Configuration and then translated the strings.

Relevant Documentation:

This topic contains 9 replies, has 2 voices.

Last updated by Carlos Rojas 3 weeks, 1 day ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 24, 2019 at 7:25 pm

milosV-3

I am trying to: In registration window, after username and pass fields, is select option with user roles to choose. In English side is fine (User, Single agent, Agency, developer), but on Serbian side, there is nothing. I translated all strings that contains those roles, but cannot see on registration window. Support of WP residance addressed to WPML.

Link to a page where the issue can be seen: hidden link

I expected to see:hidden link

Instead, I got:

September 25, 2019 at 9:41 am #4637267

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello there,

I'm truly sorry but I don't understand the issue 🙁

Can you please elaborate a little more so I can better understand?

Best regards,
Carlos

September 25, 2019 at 10:10 am #4637701

milosV-3

Sorry.
When registering in English, there is select filed to choose "user role" (User, Singl Agent, Agency and Developer). I translated those strings in all places , but on Serbian version, that select field is empty.
Attached is photo of both cases.

September 25, 2019 at 10:51 am #4637983

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

I kindly ask you to describe step-by-step how to reproduce the issue and some screenshots of the translated strings in String Translation.

Regards,
Carlos

September 25, 2019 at 12:06 pm #4638529

milosV-3

Hi,
1. go to casposla.com without logging to admin panel (as an unregistered user).
2. In the top right corner is a padlock for logging in.
3. At the bottom of modal window is a link "register", then modal window change to register form.(previously attached photo).
In English version there are select filed items, but on Serbian are not. (you may switch lang at top right menu).

Attached is screenshot of string translation.

Thank you very much!

September 25, 2019 at 2:01 pm #4639611

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Milos,

The cause of this issue was that the strings you translated weren't the ones that appeared in the form. I added the necessary code in WPML -> Settings -> Custom XML Configuration and then translated the strings.

Could you confirm that this issue is solved?

Regards,
Carlos

September 25, 2019 at 2:12 pm #4639723

milosV-3

Perfect! Thank you.
Two more questions...
1. I will be having Russian translation too, will it work or need to do some more custom code?
2. After update, will that custom settings stay or need to add it again?

Thanks!

September 25, 2019 at 2:24 pm #4639885

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

1. I will be having Russian translation too, will it work or need to do some more custom code? -> Just need to go to WPML -> String Translation -> Add the Russian translation.

2. After update, will that custom settings stay or need to add it again? -> This code will stay 😉

Regards,
Carlos

September 25, 2019 at 2:36 pm #4639915

milosV-3

My issue is resolved now. Thank you!

September 25, 2019 at 2:49 pm #4640099

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Milos,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos