Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Marcos Vinicios Barreto 1 year, 4 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 22, 2019 at 2:30 pm #3866681


The situation is this: A user with Editor role cannot duplicate posts for translation.
Clicking the Duplicate button does nothing - no error shown or any other indication.
Looking in the Network response, there's a message saying: Sorry, you are not allowed to access this page.

{"code":"wp_die","message":"Sorry, you are not allowed to access this page.","data":{"status":403},"additional_errors":[]}

Steps to reproduce:
1. Log in as admin, make sure your site have 2 languages at least (for this example, english and hebrew)
2. Create a user and set to Editor role
3. In the menu go to: WPML -> Translation Management
4. Go to Translation Roles tab.
5. Add a translator, choose the user created above and allow to translate from english to hebrew and vice versa.
6. Log in as the user created above, create a new post in English and save.
7. Now check the checkbox to translate the post to Hebrew and click the Duplicate button.

Post is duplicated to Hebrew.

Actual result:
Nothing happens, no indication of any type for something wrong. No php errors logged.

Should note: Clicking the Plus icon does work. Only the Duplicate button does not.

May 23, 2019 at 12:38 am #3870021

Marcos Vinicios Barreto

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)


Thank you for contacting WPML Support. Unfortunately, this is a known issue that our developers are aware of and working to fix. You might try the following client-suggested solution that seems to be working for people in same situation as you: Hope it helps as a workaround while an official solution is not released. Thank you for your understanding, have a nice day.