Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 3 voices.

Last updated by Yvette 1 year, 9 months ago.

Assigned support staff: Yvette.

Author Posts
April 21, 2020 at 9:03 am #5956925

jeremy

I am trying to: make WPML work properly

Link to a page where the issue can be seen: hidden link

I expected to see: lang selectors right the top menu

Instead, I got: no lang selectors

April 22, 2020 at 7:52 am #5965379

jeremy

User xxxxxxxxxxxxxxx already has more than 'max_user_connections' active connections
Array
(
[language] => en
[context] => WP Endpoints
[gettext_context] =>
[domain_name_context_md5] => xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
[name] => amp
[value] => amp
[status] => 0
[translation_priority] => optional
[allow_empty_value] =>
)

April 22, 2020 at 9:38 am #5966403

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello and thank you for contacting us.

The error message that you receive is because of limits on your server/hosting related to MySQL (the database server).

You can read more here: https://stackoverflow.com/questions/4079531/mysqli-error-user-already-has-more-than-max-user-connections-active-connectio

I suggest to contact your system administrator or hosting provider in helping you fixing that.

April 22, 2020 at 1:19 pm #5968757

jeremy

Thanks, but seems unlogic to me : I have some others sites with the same parameters (max_users_connection 151) and plugins with no errors.

Databases are equal, and provided by the same hosting company.

Here are some more details :

General

OS: Linux
Server: Apache
Hostname: xxxxxxxxxxxxxx
IP:Port: 51.68.35.212:443
Document Root: xxxxxxxxxxxxxxxxxxxx
PHP

v7.3.16
GD: bundled (2.1.0 compatible)
Memory Limit: 512,0 MiB
Max Script Execute Time: 300s
Max Post Size: 130,0 MiB
Max Upload Size: 128,0 MiB
MYSQL

v5.6.46-log
Maximum No. Connections: 151
Maximum Packet Size: 32,0 MiB
Data Disk Usage: 15,2 MiB
Index Disk Usage: 8,7 MiB

Nom du plugin Statut Actif Version
WPML Multilingual CMS Installé Oui 4.3.11
WPML CMS Nav Installé Oui 1.5.2
WPML String Translation Installé Oui 3.0.8
WPML Sticky Links Installé Oui 1.5.1
WPML Translation Management Installé Oui 2.9.5
WPML Media Installé Oui 2.1.23
WooCommerce Multilingual Non installé Non n/a
Gravity Forms Multilingual Non installé Non n/a
Yoast SEO Multilingual Non installé Non n/a
Pour bénéficier d'un accès avancé ou pour désinstaller entièrement WPML et supprimer toutes les informations linguistiques, utilisez la page de dépannage.

Pour retrouver des informations de débogage qu'une personne de l'assistance vous demanderait, consultez la page des informations de débogage.

Infos
PHP
Version 7.3.16
Limite de mémoire 512M
Utilisation de la mémoire 69.56 MB
Temps d'exécution max. 300
Max input vars 16000
Jeu de caractères Utf8mb4 Oui
Extension SimpleXML Chargée
Extension de chaîne multioctet Chargée
WordPress
Version 5.4
Multisite Non
Limite de mémoire 128M
Limite de mémoire max. 512M
REST enabled Oui

April 22, 2020 at 5:18 pm #5971007

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+01:00)

Hello

You wrote: ".. I have some others sites with the same parameters (max_users_connection 151) and plugins with no errors."

Ok. however, the error is at the server level and is related to configuration of mySQLi which is not within the scope of influence of WPML.

The solution rests in contacting your hosting provider and asking them to help you resolve this issue.