Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Noman 2 months ago.

Assigned support staff: Noman.

Author Posts
September 30, 2019 at 4:22 am #4662307

Robert

Dear support,

I'm using plugin 'Woocommerce simple auctions' and I have WPML installed in 3 languages on 3 domains. This all works flawlessly.

However, when a user on the Chinese site creates an account and places a bid he will receive the email notification in Chinese (because his user language is automatically set to Chinese). Which is good.

But the users that have Dutch and English language set in their profile will also receive an email notification in Chinese that they have been outbid.

In this case, how do I set the email notification so that every user receives the email notification in his own language?

The emails are sent with woocommerce and I've translated each email in 'wpml string translation' for 'woocommerce simple auctions' plugin.

Thank you!

September 30, 2019 at 5:22 am #4662363

Robert

No problem. Where can I send the private information to? I don't see a field where I can enter it privately.

Thank you!

September 30, 2019 at 4:54 pm #4666641

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have enabled private input box for your next reply.

Thank you

October 2, 2019 at 9:40 am #4678673

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Could you please let me know the steps to reproduce this issue. Thank you

October 3, 2019 at 2:07 am #4683799

Robert

Sure!
1) Create 2 accounts with 2 email addresses. You can create one on the .com and one on the .nl
2) Place bids with each account, so emails will be sent with each account.
3) When you place a bid with the English account, the Dutch account will receive an email in English instead of Dutch. And vice versa.
4) The goal is to have the English account only receive English emails. Dutch accounts only receiving Dutch emails. And Chinese only receiving Chinese emails.

Thank you

October 4, 2019 at 4:14 am #4692707

Robert

I'd like to add to that: the emails are sent through the woocommerce system. You can find the emails in Woocommerce>settings>email

Thank you!

October 6, 2019 at 2:43 pm #4702615

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Sorry for the delay, we ran into the weekend. Thanks for more details. I am working on this issue and get back to you with my findings.

Thank you for your cooperation and patience.

October 6, 2019 at 7:16 pm #4703211

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have tried to reproduce this issue by following the steps below:

1. Created 2 user accounts with 2 email addresses in .com and .nl respectively.
2. Then I have placed bids on this product [link_removed] with each account.
3. I have received both accounts email in English language, you can check email logs here:
[link_removed]

4. Then I created new products in each language and placed bids from opposite accounts but still received emails in English language.

Please let me know if I missed something?

Thank you

October 6, 2019 at 11:06 pm #4703497

Robert

Hi Noman,

Thank you for investigating. Yes that's right.
When 2 people place bids on the .com everybody will receive an email in English.
When 1 bid is placed on the .nl everybody will receive an email in Dutch.
When 1 bid is placed on the .cn everybody will receive in email in Chinese.

The goal is when someone places a bid on the .com or .nl the Chinese user will receive an email in Chinese.

**Would be great if you could remove our domain link from your last post.

Thank you!

October 10, 2019 at 11:19 am #4729711

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have thoroughly debugged your site and this issue. I have found that the 3rd scenario you have mentioned above is not working. Looks like this functionality is not available in all of the plugins involved here. I tried some workaround as well to make it work but unfortunately it didn’t help.

WooCommerce Simple Auction plugin is using the email functionality of WooCommerce but the content is served by WooCommerce Simple Auction itself. I cannot find this plugin in our verified compatibility list: https://wpml.org/documentation/plugins-compatibility/ so I recommend you to please ask WooCommerce Simple Auction author so they can advise you on latest compatibility of their Plugin and WPML or fix above plugin related error.

- Or you can contact one of our certified service providers for such cases who can give you more dedicated help for your site: https://wpml.org/contractors/

- Also you may like to try the latest version of the plugin:
hidden link

Thanks for your cooperation.

The topic ‘[Closed] Users receive wrong email language’ is closed to new replies.