Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by joeP-6 2 months, 4 weeks ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
August 9, 2019 at 8:00 pm #4372697

joeP-6

I am trying to: Translate a domain from English to Spanish using the Spanish domain (www.abogadolassin.com

Link to a page where the issue can be seen: hidden link

I expected to see: The website in Spanish

Instead, I got: The English version of the site. If I click on the Language switcher, it does translate it to Spanish, but It doesn't if I enter the domain hidden link

August 12, 2019 at 10:34 am #4380079

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

I need some more clarity on the issue.
The language switcher is working fine for me.

Currently, I am getting the site as given below:

hidden link => English
hidden link => Spanish

Do you want to change this?

Also, your WP Memory limit is currently 40MB. I request you to update to at least 128 MB which is the minimum requirement for WPML: https://wpml.org/home/minimum-requirements/
You can follow the steps in this link for updating WP Memory:
https://wordpress.org/support/article/editing-wp-config-php/#increasing-memory-allocated-to-php

Thanks,
Rohan

August 12, 2019 at 12:17 pm #4380693

joeP-6

Hi Rohan,
Ok, I will increase the WP memory limit to 128 MB.

I still have issues with the website. I can only see the Spanish version if click on the language switcher and change it to Spanish. When I enter the Spanish domain in the URL, it automatically sends me to the English version. Not sure why?

August 12, 2019 at 1:53 pm #4381473

joeP-6

Additionally, it seems like when I click on the actual link -www.abogadolassin.com, it does redirect me to the Spanish version but does not redirect when I enter hidden link in the url. I also notice that the theme I'm using looks a bit different than the English version. Not all of the featured images are displaying in the home page?

August 12, 2019 at 4:06 pm #4382181

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I just checked the site & the URL's are working properly.
Are you having the issue with any specific link on the menu or another area?
If so, could you please share a screenshot or URL of the same?

I have a doubt whether the issue is happening due to some cache in your browser.
So, could you please confirm this by clearing your browser cache or by checking the site in a different browser?

For better support, we handle one issue per ticket. So for the featured image issue, may I kindly ask you to open a new ticket for the same?

Thanks,
Rohan

August 12, 2019 at 6:20 pm #4383051

joeP-6

Hi Rohan,

This is the weirdest thing. I've cleared the cache on my browser and tried several different browsers but I still get the same thing. When I enter the Spanish domain in the URL, it automatically routes it to the English version. I had the client do the same thing and they see it correctly, so not sure what is happening on my end?

I created a quick video here: hidden link

August 13, 2019 at 10:06 am #4386885

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Could you please try visiting the site in a Private Window?
Also if you are using any caching plugins, could you please disable the same & check again?

Let me know the results.

Thanks
Rohan

August 23, 2019 at 3:43 pm #4448511

joeP-6

Hi Rohan, Sorry for the long delay but I'm still having issues with this. I just looked at the website and the same problem occurs. I also had someone in a different location look and they get the same issue.

Again, I can only see the Spanish version of the website if I click on the language switcher and change it to the Spanish version. When I enter the Spanish domain in the URL, it automatically sends me to the English version.

Not sure what is happening?