This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Bruno 3 months, 1 week ago.

Assigned support staff: Bruno.

Author Posts
June 19, 2019 at 1:48 pm #4051883

alanP-10

I want images from all the posts/pages/content to be used across languages, how do I do this?

June 19, 2019 at 9:19 pm #4054789

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. You must duplicate the records and then you can use the images in the secondary languages. Also, you can configure WPML so that the image registration is automatically duplicated.

You can see step by step in our documentation: https://wpml.org/documentation/getting-started-guide/media-translation/

Note: Duplicating the image registry will not duplicate the image file. The only thing that WPML duplicates is the record in the image database.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

June 20, 2019 at 1:38 pm #4060253

alanP-10

Thank-you Bruno. Please could you help me further with this issue?

It doesn't seem to work for me, attached is what I have done, then published but the image does not appear? Here is the page in Russian:

hidden link

June 20, 2019 at 7:02 pm #4062637

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for the feedback. Did you enable this option now or did you enable this option before uploading the images?

Also, have you tried saving this page again - just by clicking the "Update" button and then saving the translation again to see if the image will it be displayed as expected?

Thank you.

June 21, 2019 at 11:04 am #4066495

alanP-10

Thank-you Bruce. I enabled it after. I managed to get it working in Russian:
hidden link

but not Spanish:
hidden link

The team images do not show? I can see them all when I edit the translations but it doesn't seem to load them at all.

June 24, 2019 at 9:26 am #4075977

alanP-10

Can I have assistance please?

June 25, 2019 at 1:38 am #4080267

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sorry for the delay. As I posted above, Also, have you tried saving this page again - just by clicking the "Update" button and then saving the translation again to see if the image will it be displayed as expected?

Following the above steps, does the problem still persist? If so, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

July 8, 2019 at 8:31 pm #4165609

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I duplicated the custom fields "[CPT] Products". Following the step by step of our documentation: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

I then saved the changes to the original language and saved the changes in the secondary language (by selecting the fields that were not yet translated - selecting the "Translate is complete" option). The product is now displayed with the images.

Please, could you verify that the product is being displayed correctly now?

Thank you.

July 10, 2019 at 2:08 pm #4181193

alanP-10

Thanks Bruno, that's great you have found a solution! However I am having issues trying to recreate it on my live site.

I've duplicated the ACFs to the other languages, saved them and the product as described but still the same issue.

I feel like I am just missing out on one step?

July 12, 2019 at 3:40 am #4194731

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for the feedback. In your development environment, please try these steps:

- Open the desired product
- Scroll down and look at the "Multilingual Content setup"
- Click on the "Show system fields" link
- On the "_featured_image" select the "Copy" option. I'll attach an image for you to see.
- Click on the Apply button
- Click on the Save button
- Click to edit the translation and make sure all fields are marked as "Translate is complete" (if you do not have content for these fields, copy the original content)

If the problem still persists, this may be related to some sync that is not being performed correctly. In this case, follow the steps below:

- Open the desired product
- Using the top bar, switch to the desired language
- Click on the "Edit anyway" button
- Click on the "Update" button - you do not need to edit anything - just click "Update"

Following these steps, please let me know if the image is still not being displayed.

Thank you.

July 12, 2019 at 8:33 am #4196451

alanP-10

Excellent, thank-you for taking time in writing these steps. It works! Is there any way to do this in bulk? (in particular the copy system fields)

July 12, 2019 at 8:49 am #4196595

alanP-10

Also, is this related with ACF where I cannot translate my timeline captions on the "History" page? I tried similar steps but I can't get a translation to appear.

hidden link

July 12, 2019 at 7:01 pm #4201253

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

>>> Excellent, thank-you for taking time in writing these steps. It works! Is there any way to do this in bulk? (in particular the copy system fields)

Glad to know that this worked. For custom fields, when you configure in a post, this should be replicated in other posts too, with that same setting. You can check on other products if this option is checked, just like in the product where you configured it - is an option with global effect. The same option can be made by following the steps below:

- Click on the WPML > Settings > Custom Fields Translation
- Click on the "Show system fields" link
- Make sure that the option is selected as configured previously. Note that the option will probably already be selected as expected.

For the pages, unfortunately not. It would be necessary to take this step by step on each of the pages. That is, if the images were not synchronized, it would be necessary to access each page and follow the steps above - except the custom fields.

------

On your second question, you need to duplicate the custom fields within the ACF. To do this, follow the steps below:

- Click on the Custom Fields > Fields Groups
- Click to edit the "History" custom group
- Duplicate to the secondary languages - I did this for Russian just for you to see.
- You can now edit the page in the secondary language as well - I'll attach some pictures for you to see.

Please, by following the steps above, can you translate the content correctly?

Thank you.