This thread is resolved. Here is a description of the problem and solution.

Problem:
The client would like to add different logos for each language. The logo is set in the theme options.

Solution:
After increasing MaxInputVars, go to WPML -> Theme and plugin localization and select "Translate the theme and plugins using WPML's String Translation" (basically this turns WPML string translation "on"). Then scan the theme, go back to admin texts and select the image logo and click apply. It is now in the string translation table available for translating.

To increase MaxInputVars, add this line to your .htaccess file:

php_value max_input_vars 6000

or by following these steps:
1. Connect to your site via FTP or File Manager
2. Navigate to wp-admin folder
3. Create a file inside wp-admin folder called php.ini
4. Add in this line: max_input_vars = 6000
5. Save

If you don't have access to these files, please ask your hosting provider to do this for you.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.86 hours from now. Thank you for your understanding.

This topic contains 15 replies, has 2 voices.

Last updated by Ilana Wilner 3 years, 10 months ago.

Assigned support staff: Lauren.

Author Posts
August 17, 2016 at 8:49 am #1006388

Ilana Wilner

Hi!

Can you please let me know how to find the String Translation for the different logos per language so I can change it as appropriate?

I have followed the steps laid out in this support thread:
https://wpml.org/forums/topic/using-a-different-logo-per-language/

The instructions are clearly laid out, however when I look in WPML > String Translation to translate the logo url strings (step #7), I am not finding it.

(Btw. Like the original poster (faridM) I am also using the Qode Bridge theme.)

I have searched through all of the strings and searched through the pages and can't seem to find the string I need to change anywhere. I believe I understand what I am looking for and have successfully changed other strings, so I am not sure why I am missing it.

I have even reviewed the instructions on this page but it hasn't helped find it:
https://wpml.org/2015/07/translating-theme-options-sliders-footer-widgets/

URL of (my) website where problem appears:
hidden link

In case it helps, I have copied out all of the string translations into an Excel doc. You can download it from Dropbox here.
hidden link

Further, in case it helps to know, occasionally I see the confirmation message and sometimes it doesn't appear.... I am wondering if this is the reason it isn't appearing on the string translation page even though I have tried the same steps multiple times?

Any ideas?

Thanks!!!

August 17, 2016 at 5:45 pm #1007640

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this. Please make sure your WPML plugins and WordPress versions are all up to date.

Then, please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/. You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Next, please increase your Max Input Vars. You can do this by adding this line to your .htaccess file:

php_value max_input_vars 6000

or by following these steps:
1. Connect to your site via FTP or File Manager
2. Navigate to wp-admin folder
3. Create a file inside wp-admin folder called php.ini
4. Add in this line: max_input_vars = 6000
5. Save

If you don't have access to these files, please ask your hosting provider to do this for you.

Once those have been increased, go to WPML > String Translation and scroll down to the bottom of the page and click on the link "Translate texts in admin screens »". Then, scroll through that page and see if you find the logo string. If so, tick the checkbox and click Apply to add it to the String Translation table. Now you can go back to WPML > String Translation and you should see the string added there.

Please let me know if you need any further assistance and I will be happy to help.

August 17, 2016 at 6:58 pm #1007716

Ilana Wilner

Hi!

Thanks for your response. I have done what you suggested... I have added the memory limit to the wp-config.php file and created a php.ini file and added the line

max_input_vars = 6000

.

And then went back to click the link to "Translate texts in admin screens" and found the appropriate logo screen (image attached). I then went down to the bottom of the page to click "apply". The first time I did get a confirmation message, but still can't find the string on the WPML > String Translation page.

I went and tried it again to click the link to "Translate texts in admin screens" and clicked apply once I had made my selection and this time and further times I am not getting a confirmation message, nor can I find the logo string on the String Translation page.

I am not sure if the issue is that it isn't adding the string or if I am just missing it on the page. If it helps for trouble shooting, I can link to an excel document like last time or even give you a login access to the admin of the site as it is only in development at this point.

Please let me know what I should do next.

Thanks!!

August 17, 2016 at 8:24 pm #1007873

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

August 17, 2016 at 9:12 pm #1007894

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending the credentials. The FTP login works for me but unfortunately, the WordPress ones do not. Can you please double check and update if needed in the next reply? I have marked your next response as private. Thanks!

August 18, 2016 at 12:22 pm #1008663

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks, those credentials worked 🙂 I installed WordPress phpinfo() plugin to check your settings and it looks like your MaxInputVars are still set to 1000. This could mean that your hosting provider had a php.ini file that is overriding your settings. You can try adding this to your .htaccess and then go to Settings -> WordPress phpinfo() and see if it has increased, or contact your hosting provider and ask them to increase this for you.

Once it has been increased, please follow the steps above to add it to the string translation table. Let me know if you are able to add it this time.

August 19, 2016 at 5:06 pm #1011028

Ilana Wilner

Hi Lauren

Thanks for all of your help.

I spoke to our hosting company as whenever I changed the MaxInputVars in the .htacccess file it resulted in a 500 internal error.

They have changed it now... so now when I check in the php info plugin it says "6000".

However, it still isn't working when I try to get the string translations to work. It isn't giving me a confirmation message when I apply it, and when I search for 'logo' to find it after it isn't there. I have tried it several times.

Is there another way of doing this?

Thanks!

August 19, 2016 at 6:20 pm #1011333

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I went to WPML > Theme and plugin localization and selected "Translate the theme and plugins using WPML's String Translation" (basically this turns WPML string translation "on"). Then I scanned your theme, went back to admin texts and selected the image logo and clicked apply. It is now in your string translation table available for translating.

Please let me know if you need any further assistance and I will be happy to help.

August 19, 2016 at 6:41 pm #1011376

Ilana Wilner

THANK YOU!!!

I was able to see the item and change it to the translation.

I then tried to do the same steps as you to get a second item working "logo_image_mobile" - including the rescan of the 'Strings in the Theme'. But it isn't working for me still. I can see when I go to the page that there is a checkmark on the page beside the one that you did - but no checkmark for the one that I am doing, nor am I getting a confirmation message when I hit 'apply'. I am not sure why it still isn't working.

But.... as it looks like it is working for you and I should only need one more item done (hopefully ever!).... Can you please make it so that I can I edit the string for "logo_image_mobile".

Thanks for this amazing support!!! Really appreciate it!!

August 19, 2016 at 9:34 pm #1011570

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I tried following the same steps and I wasn't able to add it either 😉

Would you be able to temporarily deactivate all plugins other than WPML related plugins and see if you can then add the logo image string following the steps above? I'm trying to see if I can isolate the issue in the event there is a conflict with another plugin.

August 19, 2016 at 9:39 pm #1011573

Ilana Wilner

I will do this and report back. I was also wondering if it may have to do with WordPress v.4.6?

August 19, 2016 at 9:47 pm #1011576

Ilana Wilner

I just deactivated all of the plugins and redid the usual steps including rescanning.... Still no string translation...

August 19, 2016 at 10:53 pm #1011587

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for testing that for me.

I'd like to have you install a beta version that was released to see if this resolves the issue. Please make a full backup of your entire site before proceeding.

You can download the beta version at http://www.wpml.org/account/downloads) scroll to the bottom for the beta release named CMS Beta Package). Once you download it, please manually upload the folder via FTP. Then, try to add the admin text to the String Translation table and let me know if it gets added.

Please let me know if you need any assistance installing the beta package and I will be happy to help.

August 20, 2016 at 7:48 pm #1012062

Ilana Wilner

No... 🙁

I downloaded the beta as requested and have installed it. Btw. in doing so I noticed that all my settings were saved except the "Translate the theme and plugins using WPML's String Translation" was deselected. I turned this back on and did the usual routine including the scan. Unfortunately it isn't working.

I only have the WPML Multilingual CMS and the WPML String Translation installed. Are there any other ones that I should try that may help this?

August 22, 2016 at 10:47 pm #1014932

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I was able to add the string to your theme's Language Configuration file and the mobile logo is now showing up in your string translation table. To do this, I opened up wpml-config.xml and added this line to the admin-texts section:
<key name="logo_image_mobile" />

Please let me know if you need any further assistance and I will be happy to help.