This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by geoffroyD-7 3 months, 2 weeks ago.

Assigned support staff: Laura.

Author Posts
July 3, 2019 at 1:20 pm

geoffroyD-7

Hello,

I am trying to switch from using the Classic translation editor to the advanced editor and use it to translate my contact forms (I am using Contact Forms 7 + popup maker).

To do so, I deleted all previously translated contact forms and translated them using the advanced editor. I also changed the settings and translated the popups with the advanced editor, as suggested here: https://wpml.org/documentation/plugins-compatibility/using-contact-form-7-with-wpml/

But on the website, the contact form doesn't show up on the translated pages. On the original language page, the forms show up but without the title.

Second issue, which might be related: I changed the settings to have the content that was created in the Classic Editor to "switch to usig the advanced translation editor", but this doesn't work. All my translations still appear in the classic editor.

Any idea what might be going on here?

Thank you,
Josephine

July 3, 2019 at 3:24 pm
July 3, 2019 at 4:02 pm #4138079

geoffroyD-7

Hi, I tried to reproduce the error on the sandbox but I can't seem to upload my theme there.

I already created the button and the popupmaker but I have never used the classical editor, so I don't know how to add it to a button without my theme.

I use the "Enfold" theme but I can't find it in the themes search.

July 4, 2019 at 7:01 am #4140579

geoffroyD-7

Hello,

I tried it again this morning but no luck, I can configure a pop up on the classic editor.

Can you still help me with my issue?

July 4, 2019 at 7:24 am #4140731

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

you don't see Enfold in the theme search because it's a paid theme, and therefore you need a license to install it.
Have you checked the plugin's documentation? I don't know it so I'm not sure what is the procedure here. What do you mean with Classical editor? The WPML or the WP one?

July 4, 2019 at 7:27 am #4140769

geoffroyD-7

Hello, I meant the WP one.
When I follow the popup maker's documentation, the popup doesn't show up on the page. I can try and contact them to see how to get it working.

July 4, 2019 at 2:57 pm #4144705

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Ok, let me know if you can find a solution.

July 4, 2019 at 3:03 pm #4144739

geoffroyD-7

I am waiting for an answer from them, they don't see why it doesn't work either at first sight.
I will let you know.

July 5, 2019 at 6:14 am #4147911

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Sure, thank you.

July 5, 2019 at 7:34 am #4148615

geoffroyD-7

Hello,

I have configured the popup in English on the sandbox. I have the same issue as on my website, meaning that the title doesn't appear. I am checking with popup maker why this is so.

I don't have the WPML contact form plugin installed on the sandbox. Could you maybe give me access to it so that I can do the translations and reproduce the error?

Thank you,
Josephine

July 5, 2019 at 9:53 am #4149963

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi Josephine,

I installed the add-on but if the issue is with the pop-up plugin I don't think it will make a difference.

Which are the steps to reproduce the issue?

July 5, 2019 at 9:57 am #4150023

geoffroyD-7

Well, I don't know if it's the popup plugin.

The forms did not appear on translations only on my website. I have now re-created the current english version on the sandbox and I will translate the forms using the same settings as on my website to see if the issues are the same.

July 5, 2019 at 1:05 pm #4151471

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Yes, but if all the forms you had on the website, the only correctly translated was the one without the popup plugin I think there are good chances it's the culprit, also because it isn't tested as WPML compatible.

July 5, 2019 at 1:09 pm #4151505

geoffroyD-7

Hello, the sandbox was not working, I got an error message when trying to use the advanced WPML editor.

However, i have digged a bit further on my own website and have found saving issues (a new field for "language" appeared that needed to be translated). With translation to 100%, the forms now appear in the popups.

Also I needed to change some of the WPML settings regarding what needs to be translated or not.

Anyway, it does work now. Only the title that isn't appearing, but that seems more like a popupmaker issue than a wpml one.

July 5, 2019 at 2:35 pm #4152187

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

glad to know it's solved. If you need help with the title, please let me know.