This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Author Posts
April 13, 2017 at 8:20 am #1253500

ramezG

I am using the latest version of Visual composer which all my content and theme uses to build the pages.

I have followed all your tutorials and looked through all your help topics.

For some reason when translating the page the page builder doesnt show up and only two fields for body and title.

I have done all the steps regarding scanning the theme and plugins for strings etc..

Please if you can get back to me asap. Happy to supply Login details as the site is maintenance mode untill client approves it.

Thanks

April 13, 2017 at 8:37 am #1253539

Joanna

Hello @ramezg,

It seems that you are missing the correct language configuration file for Visual Composer.
You can find the current version at hidden link.

You can find more about translating pages built with Visual Composer at https://wpml.org/documentation/plugins-compatibility/visual-composer/.

If you use any additional shortcodes, you may need to create the additional language configuration file and upload it to the root folder of the theme or the plugin that implements additional shortcodes.

You can read more about language configuration files at https://wpml.org/documentation/support/language-configuration-files/
https://wpml.org/documentation/support/wpml-integration-with-page-builders-that-use-shortcodes/

April 13, 2017 at 8:41 am #1253542

ramezG

Thanks for the reply.

Where do i place the current version of visual composer configuration file that you supplied? and do i need to rename it?

thanks

April 13, 2017 at 3:23 pm #1253926

Joanna

Hello @ramezg,

The file should be uploaded to the root folder of Visual Composer. It should be called wpml-config.xml. If you already have one, you can compare these files and adjust the existing file according to the one I shared with you.

You may also need to re-save the page in the original language afterward to refresh the settings.