Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Diego Pereira 1 year, 2 months ago.

Assigned support staff: Diego Pereira.

Author Posts
October 2, 2018 at 1:47 pm #2781716

mathieuR-9

I am trying to: translate pages using WPBakery and WPML

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link with the translated content

Instead, I got: a broken page with nothing.
The only way i can "translate" is by turning off the regular translation, use advanced translation, and copy/paste the english content and translate everything instead of just the fields like it's supposed to do.
If there is no other option, ill go with that.

October 2, 2018 at 1:56 pm #2781735

mathieuR-9

If i use the regular translation, with only fields to translate… the page loads (header, footer…) but the content of wpbakery just does not load at all. Attached, the homepage as an example.

October 2, 2018 at 1:58 pm #2781750

mathieuR-9

More screenshots of the translation tool… and the code displayed (main section, loads a post suppsedly… but empty.)

October 4, 2018 at 4:53 pm #2788357

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @mathieur-9, welcome to the WPML support Forum!

For translation to be published, all fields must be marked "Translation is complete," and translation status must be set to 100% complete. Is your page set this way?

Please check if the same issue occurs using the Manual Editor:
- Go to the edit screen of the page (default language)
- Change the language using the Language Switcher at the top admin bar
- If it display a warning, click on "Edit Anyway"

Please enable WP_Debug on your website, it will display more details about the error: https://wpml.org/documentation/support/debugging-wpml/

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.
NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

All the best,
Diego