This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 35 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 6 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
February 21, 2019 at 2:30 pm #3228009

jernejH

Hi!

I know that is possible to run WPML on different domains, using "A different domain per language" setting. I just want to know what else should I consider to setup regarding "other" domain.

Let's say i have this situation:

WooCoomerce shop is up and running on mydomain.si. I have also mydomain.hr domain, on which I would like to run "the second" shop (which is the same, except translated to croatian language). Is there anything special I have to setup for .hr domain in cpanel in order to this work?

I'm using flatsome theme 3.5.3 wit WooCommerce 3.4.5.

Thanks!

Jernej

February 21, 2019 at 7:25 pm #3229732

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It is needed to adjust your DNS and server settings to make it work, you find the full details on how to setup WPML for different domains at: https://wpml.org/2016/04/use-wpml-different-domains-per-language/. Please, let me know if it helps, have a nice day.

February 27, 2019 at 1:38 pm #3250475

jernejH

Hi!

I have cPanel access. If I add addon domain in this all I should do? What about "Setting up your HTTP server"? Is this something my hosting provider should do?

Regards,
Jernej

February 27, 2019 at 7:28 pm #3252320

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. After adding your addon domain using your CPanel you would need to setup your HTTP server, here the only to edit it should be with the proper rights to manage your server, if you are not sure on how to proceed here, I recommend you to get in touch with your host support in order to learn more on how to proceed with Apache or Nginx configuration. Hope it brings a bit of clarifications for you, please, let me know if you need any additional clarifications from our side, have a nice day.

February 27, 2019 at 10:47 pm #3252692

jernejH

Hi!

Ok, I'll contact hosting provider and we'll see 🙂

One more question...in order to correctly setup store on both domains (.si and .hr) I probably need WooCommerce Multilingual plugin too, or?

Regards,
Jernej

February 28, 2019 at 12:06 pm #3255059

jernejH

Hi!

Situation is now like this:
.hr domain is added as addon domain. Hosting provider has done it all, as told in your instructions.

If i now open .hr domain, it opens this: hidden link

WPML is configured like this: hidden link. I have set this just now.

Should we wait a bit or is there something else I need to do?

Regards,
Jernej

February 28, 2019 at 2:58 pm #3255979

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Regarding your questions:

"1 - In order to correctly setup store on both domains (.si and .hr) I probably need WooCommerce Multilingual plugin too, or?"

WooCommerce Multilingual will help you to easily translate your products content and attributes using a unified interface but it is not required to run your website using the multi domain setup.

"2 - Should we wait a bit or is there something else I need to do?"

From the provided screenshots, it seems your DNS is fully propagated and pointing to your server, please, make sure your addon domain is really point to the same location of your default domain, in other words, you need to make sure your addon domain is point to your server folder of your WordPress installation.

Please, let me know if you need any additional clarifications, have a nice day.

February 28, 2019 at 6:35 pm #3257081

jernejH

Hi!

1. Cool, thanks 🙂

2. I think everything is correct, addon is pointed to public_html, right where is WP installation -> hidden link. But at this point, if I open .hr domain, it redirects me to .si domain. Maybe coz no translation of pages is yet made?

Regards,
Jernej

February 28, 2019 at 7:22 pm #3257211

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Jernej,

Thank you for the updates. Please, create a test page and translate it in order to confirm if you can view both the default page and the translated one using your multi domain setup. Please, let me know the results, have a nice day.

February 28, 2019 at 7:30 pm #3257223

jernejH

Hi!

I've created test page and translated it and it opens correct on .hr domain :).

But...when i've created .si (this is main domain) test page and then when I hit "translate" button, I was logged out of WP and login page was in "croatian" language. I was able to login with my credentials and everything was fine.
I'm just wondering if its going to logged me out each time I hit "translate" page? :O 🙂

Regards,
Jernej

March 1, 2019 at 2:43 am #3258224

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. It is a weird behavior I haven't further reports regarding it, I would like to give a further look in order to understand what's going on, for that, please consider: I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

March 1, 2019 at 10:20 am #3259607

jernejH

Hi!

Update...I just try to add another translation and everything looks ok now.
Can you still try it for yourself, just to be sure?

And one more thing...how can I set "homepage" to .hr domain. Just by adding translation?

Thank you!

Regards,
Jernej

March 1, 2019 at 1:32 pm #3261039

jernejH

Hi!

Another update. I was trying to duplicate (add translation) for homepage but when I hit "Copy content from..." it's stucked -> hidden link

Regards,
Jernej

March 1, 2019 at 4:07 pm #3262101

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Jernej,

Thank you for the updates. I tried to access the WordPress Dashboard of your website to give it a detailed look but it seems your website has some sort of protection based on country, please, temporary disable this protection or whitelist Brazil for your blocked countries list. Thank you for your collaboration, have a nice day.

March 4, 2019 at 7:48 am #3267365

jernejH

Hi!

Please try now 😉

Regards,
Jernej