Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Cristina 4 years, 2 months ago.

Assigned support staff: Cristina.

Author Posts
November 10, 2017 at 2:48 am #1426641

danielL-65

Validation page (hidden link):

' I’ve read and accept the terms & conditions * '
' Create account password '

When someone tries to log in (hidden link):
' Error, the password you've entered is wrong'

How can I translate them?

Screen Shot 2017-11-10 at 1.47.07 pm.png
November 10, 2017 at 3:09 pm #1427155

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi daniel,

Thank you for contacting our support forum.

Would you mind providing me with admin access to the website so that I can have a look at this for you ?

The private fields will be enabled for your next response.

Thanks,
Shane

November 13, 2017 at 2:33 pm #1429041

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Daniel,

I was able to see the issue, however would you mind temporarily disable all the non-wpml plugins with the exception of woocommerce and check aagain to see if this text is translated?

I can see that you've done the translations on the backend already.

Please try this and let me know.
Thanks,
Shane

November 18, 2017 at 2:52 am #1434501

danielL-65

I've created a staging site and disabled all plugins except those that you said. Same login details as above. The issue still exists.

November 18, 2017 at 2:53 am #1434502

danielL-65

staging3.alsportswear.com

November 18, 2017 at 3:26 am #1434505

danielL-65

Sorry correct URL for staging is staging2.alsportswear.com

November 22, 2017 at 10:09 am #1437933

Cristina

Hello Daniel,

sorry for the delays with an answer.

As Shane is not available I have taken this ticket now to deal with your case.

I could login to the staging site, but you have disabled the main WPML plugins. Translations for admin strings like the ones in the checkout form have to use WPML String Translation to show the admin texts in the second language and is required also for WooCommerce Multilingual to work.

Can I work on this site enabling and using the plugins to check the issue?

Kind regards,
Cristina

November 23, 2017 at 2:46 pm #1439453

danielL-65

Hi, Chistina, The staging site is yours to play with. Deactivate and activated plugins as you
like.

November 29, 2017 at 8:22 pm #1445228

Cristina

Hello Daniel,

sorry for the delays.

To get the string to show in String Translation you have to rescan WooCommerce with the option "assume that all texts in PHP Strings are in English" NOT enabled.

Though WooCommerce strings are english, you default language is french. If you scan the plugins or themes or themes with that option enabled, they don't show correctly on the frontend.

I have rescanned WooCommerce without this checkbox enabled and then searching for "conditions" in the WooCommerce text-domain shows the english string.

I have translated it for you to french and now it shows on the checkout page / validation page. See the screenshots attached for the settings. You can do the same in the main site.

Kind regards,
Cristina

ValidationOK.png
Validation2.png
Validation1.png