This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: My products and variations are not displayed in secondary languages.

Solution: Be sure that the following setting is not set: - WPML > WooCommerce Multilingual. - Multicurrency. x Show only products with custom prices in secondary currencies

Relevant Documentation: https://wpml.org/documentation/related-projects/woocommerce-multilingual/multi-currency-support-woocommerce/

This topic contains 8 replies, has 2 voices.

Last updated by Andrés 3 years, 2 months ago.

Assigned support staff: Andrés.

Author Posts
August 7, 2016 at 5:45 pm #993289

marcH-8

I am trying to:
I have set up a variable product in the same way I have set up another variable product. SKUs are different, stock management is not enabled, products are on stock though. However, the products shows: "This product is currently out of stock and unavailable..
The strange this is that the other variable product I had WORKED before!!!! Now, also this other product doesn't work and shows the out of stock notice!! This is really strange. I haven't tried with all plugins disabled, but between the other product (that has been working) and the new product I haven't installed other plugins. So, there must be some other reason why it stopped working.

URL of (my) website where problem appears:
hidden link
and
hidden link
the latter one has been working before!!

I have latest wp, woocommerce, wpml and other plugin versions, all updated.

August 8, 2016 at 8:37 am #993696

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Marc,

Welcome to WPML support forum.

1. Could you please go to:
- WPML > WooCommerce Multilingual > Status.
- Click con the "Troubleshooting page" link.
x Sync products variations.
x Click on the Start button.

Does it help? If it does not:

2. Please check if this issue appears when:
- All non WPML Plugins are disabled. It will tell us if there is an interaction issue with other plugin.
- Theme is set to a WordPress default like Twenty Fourteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

I'll wait for your comments.

Best regards,
Andrés

August 8, 2016 at 1:31 pm #994425

marcH-8

Hi Andrés,

I synced the product variations (and also the categories, just to be sure), no success!

BUT.... I have done as you said and deactivated all plugins (besides those I need for the theme and visual composer). AND.. it worked!! I have found the "problem plugin" !!!
It's woocommerce multilingual!!
And I found out that deactivating this plugin it also solves my other problem where some products are not shown.
I have the latest version of Woocommerce multilinugal (Version 3.8.4). So, there are any known issues with this plugin and wpml?? I would really need to use this plugin for my multilanguage site.
Any idea?
thanks, marc

August 8, 2016 at 3:10 pm #994711

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Yes, WooCommerce Multilingual it is necessary for having a multilingual e-commerce site as it would sync your stock, prices, orders... So, let's see what else could be happening there:

1. It would be good if you can provide me the WordPress debug.log (not WPML debug informations). Please check this page for instructions
https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way, because sometimes the logs are long and create a complete mess in discussion).

Regards,
Andrés

August 8, 2016 at 6:24 pm #994970

marcH-8

Hi Andrés,

first of all, thanks a lot for your help, WPML has a superb support!! 😉

So, I have created the debug.log, but there is only one error (that repeats) and it's related to the table rate plugin. I have also deactivated this plugin, but that's not the reason of my errors. With disabled woocommerce multilingual but ENABLED table rate I have no problems!! So, it's definitely the woocommerce multilingual that's causing the problems. But in the debug there is no error for it!
I have been going through the shop pages (that ones that make problems) while the debug mode was enabled.

Here's the pastebin link of the log:
http://pastebin.com/bhhVMWY7

thanks, marc

August 9, 2016 at 9:37 am #995736

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Marc,

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue. Could you please indicate me how to replicate this behaviour?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!
You can use a plugin for this if you like. You can use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

August 9, 2016 at 2:01 pm #996280

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Marc,

For support rules, we are able to handle only one issue at the time. This help us to bring you a better service and also help other users to find all the information here exposed. For that reason I have to kindly ask you to open a new thread if you need further assistance.

So, I think I have found the solution for your second problem. You have selected the following setting:
- WPML > WooCommerce Multilingual.
- Multicurrency.
x Show only products with custom prices in secondary currencies

It means that if you don't fill a custom price for your secondary currencies, variations won't be showed. Unchecking that setting display your variations.

Does it solve your issues? If yes, now we can continue in your other open ticket.

Thank you for your understanding.
Best regards,
Andrés

August 9, 2016 at 7:45 pm #996843

marcH-8

Hi Andrés,

I thought (and still think) that both issues are related and have the same cause in common. That's why I put both in one ticket. And voilà, it seems that both issues are solved indeed! Not only the variable product is working, but also I can see all the other products that have not been visible before. If the problem should persist or return, I will open a new ticket.

So, it was a setting problem. Maybe not only variable products but also standard products have not been shown due to this wrong setting???

Therefore it showed products in Euro (main currency) and not products that did not have custom prices in secondary currency!! Right?!
Great!

Thanks for your help!!

August 10, 2016 at 9:44 am #997453

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Marc,

I'm glad to know your problem was solved.

And you are right about it, both problems were caused for the same setting that doens't display any product unless you set a custom price.

Have a nice day,
Andrés