This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 35 replies, has 2 voices.

Last updated by Daniela 4 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
June 11, 2019 at 5:43 am #3991975

Daniela

Ich muss mich wirklich zusammenreißen, noch höflich zu bleiben. Diese Konversation ist mehr als frustrierend. Lesen Sie eigentlich meine Kommentare überhaupt? Haben Sie sich den Testshop tatsächlich angeschaut? Ich hatte Ihnen doch mitgeteilt, dass ich die Version von Woocommerce Multilingual auf 4.3.7 zurückgespielt habe und es mit der Version funktioniert. Ihre Testbestellung haben Sie nun mit der Version 4.3.7 durchgeführt! Ergo tritt das Problem nicht auf!
Es hat auch nichts mit einer als nicht abgeschlossenen Übersetzung zu tun. Wenn das der Fall wäre, würde es eher die englische Übersetzung beeinflussen, denn dieses wäre ja nicht abgeschlossen, und nicht die Originalversion des Produkts! Außerdem habe ich bereits im Ausgangspost, den Sie ja nicht wirklich gelesen haben, wie man an Ihren bisherigen Antworten erkennt, erläutert, dass wenn der Fehler auftritt, ich das Produkt in der Originalsprache jedes Mal aktualisieren muss, damit der Fehler wieder verschwindet. Das hatte ich vor dem Downgrade auf 4.3.7 gemacht und lediglich dann die Übersetzung nicht erneut aktualisiert.
Sie sollten herausfinden, warum die neuen Versionen von Woocommerce Multilingual die von mir detailliert beschriebenen Probleme verursachen. Auch gehen Sie in keinster Weise auf die Probleme mit den Endpoints ein, die ja mehrere Kunden hier im Forum in den letzten Monaten angesprochen haben!
Bitte leiten Sie mein Problem an einen Kollegen weiter, der wenigstens in der Lage ist, meine Kommentare zu lesen und sich ernsthaft bemüht, den Fehler tatsächlich zu suchen! Sie sind anscheinend nicht in der Lage dazu!

June 11, 2019 at 5:09 pm #3997567

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Bitte rekonstruieren Sie das Problem auf der folgenden Test-Site:

Ein-Klick-Login: hidden link

Sollte das Problem auf dieser neuen Installation gleichfalls auftreten, senden Sie mir bitte eine kurze Benachrichtigung und ich werden den Vorgang an unser Kompatibilitäts-Team weiterleiten.

Mit freundlichen Grüßen
Andreas

June 11, 2019 at 6:04 pm #3997921

Daniela

Die Login Daten zu der url?

June 11, 2019 at 10:47 pm #3998755

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich muss mich ehrlich bei Ihnen entschuldigen, aber ich kann mir nicht erklären, wieso mir bei diesem Ticket so vieles missraten ist. Es sollte eigentlich ein Ein-Klick-Login Link sein, den ich Ihnen gesendet habe.

Des Weiteren hoffe ich, dass Sie Verständnis dafür aufbringen können, dass wir im Support ein sehr hohes Arbeitspensum haben und von einem Ticket zum anderen wechseln.

Ich habe nun eine minimale Installation auf der folgenden Sandbox installiert:

One Click Login:hidden link

Ich habe hier nun einen Test mit dem Generate Press Theme und CMS Multilingual, Translation Management, String Translation, Media Translation und WooCommerce Multilingual in ihren aktuellsten Versionen durchgeführt.

Es gab mit diesem Setup keine Probleme beim Übersetzen, wie auch beim Einkaufsvorgang. Ich lade Sie gerne ein das auf der Sandbox selbst zu testen.

Ich möchte zusätzlich erwähnen, dass ich wie in meiner zweiten Nachricht bereits erwähnt das WP-debug Feature kurzzeitig auf Ihrer Website aktiviert hatte und es wurde dabei kein Fehler wiedergegeben.

Des Weiteren haben wir heute neue Versionen von CMS Multilingual, Translation Management und String Translation veröffentlicht. Führen Sie bitte die Aktualisierungen durch und prüfen Sie, ob das Problem weiterhin besteht. Diese Versionen wurden ebenfalls bei meinem Test verwendet.

Das Sie mir mitteilten, dass das Problem auf Ihrer Website auch dann auftritt, wenn alleine WooCommerce, CMS Multilingual und WooCommerce Multilingual aktiv sind, kann ich mir nicht erklären, warum ich das Problem nicht auf einer neuen Installation reproduzieren kann.

Im Grunde muss ich gestehen, dass mich Ihre erste Nachricht, welche auf Englisch war ein wenig verwirte, da ich daraus nicht erkannte, dass sich das Problem mit dem Originalprodukt befasst.
Zitat: "If a customer places an order for a product with variants in English, the 2nd language, the variant selection disappears in German, the main language,..."

Entschuldigen Sie bitte, dass ich nicht gleich gemerkt habe, dass das eigentliche Problem alleine bei der Darstellungen der Produktvariaten eines einzelnen Originalproduktes besteht.
Wie ich allerdings auch bereits erwähnt habe, kann es sich eigentlich nicht um einen Bug handeln, wenn es nur bei einem Produkt einen Fehler gibt und andere Produkte unbetroffen sind. Ich vermute eher der Fehelr tritt aus einem anderen Grund auf.

Ich habe auf Ihrer Test-Site nun WooCommerce Multilingual wieder auf die aktuelle Version aktualisiert. Danach gab ich dem Originalprodukt "Vellus Satin Cream" (Deutsch) ein unbeutendes Update (Leerzeichen), aktualisierte es und übersetze es erneut auf Englisch.

Ich führte dann weitere Testeinkäufe durch und konnten kein Problem feststellen. Die Produktvarianten auf der deutschen Produktseite für VELLUS SATIN CREAM werden weiterhin im Originalprodukt, wie auch in der Übersetzung angezeigt.

Haben Sie eventuell bemerkt wann genau die Produktvarianten auf dem Front End nicht mehr sichtbar sind?

Mit freundlichen Grüßen
Andreas

June 12, 2019 at 1:51 pm #4004897

Daniela

Leider ist das Problem noch da. Habe gerade eine englische Testbestellung durchgeführt. Dann bin ich wieder auf die deutsche Shopseite, habe das Produkt angeschaut, keine Ausführung (Inhalt) wählbar. Und leider betrifft es auch nicht nur dieses eine Produkt, sondern immer wieder andere, ohne einen direkten Zusammenhang. Also Produkte aus diversen Kategorien.

Ich nehme an, dass der Fehler schon länger bestand und ich ihn erst jetzt aufgrund von Kundenbeschwerden bemerkt habe. Wahrscheinlich seit dem Update von Woocommerce Multilingual auf 4.4.0, denn bis 4.3.7 funktioniert alles.

Die WP debug Aktivierung hatte ich schon bevor ich überhaupt dieses Anliegen hier im Forum gepostet hatte probiert und ebenfalls keine Fehlermeldungen. Das ist ja das Problem. Es gibt nirgends Fehlermeldungen. Ausser im Server error log eine PHP Warnung:
PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/ador/apps/test/wp-content/plugins/woocommerce-multilingual/compatibility/class-wcml-variation-swatches-and-photos.php on line 57

Laut Kompatibilitätscheck auf der WPML Seite ist das „Variation Swatches and Photos Plugin“ aber erst kürzlich von WPML getestet worden und als kompatibel eingestuft.

Schade, denn Ihre Lösung eines einfachen Leerzeichens wäre zu schön gewesen.

Ihre Sandbox Lösung ist ja nun komplett neu, da wird es schwer sein, einen so mysteriösen Fehler nachzustellen, ausser ich importiere meine Datenbank in Ihre Sandbox, dann könnte der Fehler mitunter evtl. auch auftreten. Ich nutze WPML ja nun schon einige Monate/Jahre. Zwischenzeitlich gab es unzählige Änderungen in Ihren Plugins als auch in Woocommerce teils mit größeren Code Veränderungen. Da wird irgendein Update zwischen den Plugins in meinem ja schon älteren Shop nicht richtig funktioniert haben oder eine Datenbankaktualisierungen, die ja auch mehrmals durch Updates des Woocommerce Plugin in den letzten Monaten vorgenommen wurden.

Die einzige Lösung momentan ist, meine Live Shops erstmal auf Version 4.3.7. zu belassen und zu hoffen, das irgendein zukünftiges Update den seltsamen Fehler behebt.

Übrigens kann ich keine der anderen WPML Plugins auf der Testseite aktualisieren:
Aktualisierung des Plugins WPML Multilingual CMS (1 von 1)
Herunterladen der Aktualisierung von https://wpml.org/?download=6088&version=4.2.7&site_key=vOTfTJFEmF&site_url=http%3A%2F%2Ftest.adorablepaws.de&wpml_version=4.2.6
Entpacken der aktualisierten Version …
Beim Aktualisieren von WPML Multilingual CMS ist ein Fehler aufgetreten: Das Paket konnte nicht installiert werden. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

Auch im Download auf der WPML Seite erscheinen diese neuen Versionen (noch) nicht zum Download:
https://wpml.org/account/downloads/

June 12, 2019 at 7:09 pm #4007245

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich werde den L2 Support bezüglich des Server-Errors, welchen Sie mitgeteilt haben, konsultieren und melde mich sobald ich Neuigkeiten habe.

Es könnte Sie, dass das Problem mit dem Browser Caching zusammenhängt. Sie könnten die versuchen die .htaccess Datei editieren, um so Broswer Caching für die Website zu deaktiveren?

Mehr Information dazu hier:
hidden link

Kind regards
Andreas

June 13, 2019 at 7:38 am #4010235

Daniela

Hallo Andreas,

Browser Caching zu deaktivieren hilft auch nicht.

Weil auf der Testseite, die ich Ihnen erstellt hatte jetzt schon so viel "rumprobiert" wurde, habe ich erneut eine Kopie meines Live Shops erstellt und eine weitere Fehlermeldung bekommen:

Fehler-Details
==============
Ein Fehler vom Typ E_ERROR wurde in der Zeile 78 der Datei /var/www/ador/apps/test2/wp-content/plugins/woocommerce-variation-swatches-and-photos/classes/class-wc-swatches-compatibility.php verursacht. Fehlermeldung: Uncaught Error: Call to a member function get_attribute_taxonomies() on null in /var/www/ador/apps/test2/wp-content/plugins/woocommerce-variation-swatches-and-photos/classes/class-wc-swatches-compatibility.php:78
Stack trace:
#0 /var/www/ador/apps/test2/wp-content/plugins/woocommerce-variation-swatches-and-photos/classes/class-wc-swatches-product-attribute-images.php(48): WC_Swatches_Compatibility::wc_get_attribute_taxonomies()
#1 /var/www/ador/apps/test2/wp-includes/class-wp-hook.php(286): WC_Swatches_Product_Attribute_Images->on_admin_init('')
#2 /var/www/ador/apps/test2/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#3 /var/www/ador/apps/test2/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#4 /var/www/ador/apps/test2/wp-admin/admin.php(169): do_action('admin_init')
#5 /var/www/ador/apps/test2/wp-admin/plugin-install.php(16): require_once('/var/www/ador/a...')
#6 {main}
thrown

Vielleicht ein Zusammenhang zu der Warnung PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/ador/apps/test/wp-content/plugins/woocommerce-multilingual/compatibility/class-wcml-variation-swatches-and-photos.php on line 57

Eventuell gibt es doch Kompatibilitätsprobleme zwischen WMPL und dem Swatches Plugin? Ich werde noch ein bisschen testen, Plugins deaktivieren, löschen, neu installieren, etc. Falls ich Weiteres finde, gebe ich Bescheid.

June 13, 2019 at 5:45 pm #4016031

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Wir haben am 12.Juni WooCommerce Multilingual 4.6.5 veröffentlicht. Das Update steht auf Ihrer Website bereit.

Bitte führen Sie die Aktualisierung durch und kontaktieren Sie uns, sollte das Problem erneut auftreten.

Alterantiv können Sie die Plugins hier herunterladen:
https://wpml.org/account/downloads/

Die von mir erstellte Sandbox Test-Site ist sogar bereits seit mehren Tagen unter der WCML Version Version 4.6.3 online und es gab keine Probleme bezüglich der Produktvarianten.

One Click Login: hidden link

Bitte installieren Sie das Plugin https://wordpress.org/plugins/aryo-activity-log/ um auf diese Weise zu sehen, welche Aktivitäten zuletzt durchgeführt wurden, sollte das Problem erneut auftreten.

Sie können auch gerne auf der von mir erstellten Test-Site einige Tests druchführen, indem Sie Plugins, die auf Ihrer Website verwendet werden hinzufügen und aktivieren und so prüfen, ob das Problem nicht doch im Zusammenhang mit einem anderen Plugin stehen könnte.

Die Fehlermeldung, welche Sie uns mitgeteilt haben bezieht sich auf das Plugin WooCommerce Variation Swatches and Photos. Könnten Sie dieses Plugin bitte auf der oben erwähnten Sandbox Test-Site installieren und mich informieren, sobald dies geschehen ist?

Mit freundlichen Grüßen
Andreas

June 14, 2019 at 8:08 am #4019107

Daniela

Hallo,
ich habe Woocommerce Multilingual auf Version 4.6.5 aktualisiert. Der Fehler besteht weiterhin 🙁 Auch ein deaktivieren bzw. löschen des Plugins Variation Swatches hilft nicht. Fehler bleibt.
Habe dann WPML testweise komplett gelöscht (alle Übersetzungen manuell) und deinstalliert. Neu installiert, neu eingerichtet, Produkt übersetzt, Fehler wieder da!
Auf Ihrer Sandbox Seite habe ich Ihnen das Swatches Plugin installiert und auch testweise meine Produkte importiert, was aber nicht vollständig gelungen ist. Der Import bricht immer ab. Es erscheint auch auf Ihrer Seite eine Fehlermeldung: Wir haben erkannt, dass das Feld product_type für manche Produktübersetzungen falsch eingestellt war. Dies ist passiert, weil die Taxonomie product_type übersetzt wurde
Trotzdem funktionierte dort die Bestellung.
Es wird wohl doch ein Datenbankproblem auf meiner Seite sein. Sehr seltsam, denn ich mache keine Änderungen dort. Es muss also definitiv mit dem letzten großen Woocommerce Update, glaube das war Mitte/Ende April zusammenhängen. Dort gab es ja u.A. Datenbankaktualisierungen.
Bleibt wohl nur, den Shop komplett neu aufzusetzen. Wie auch immer, bis dahin werde ich erstmal auf meiner Shop Seite Ihr Woocommerce Multilingual auf Version 4.3.7 lassen, denn mit der Version funktioniert alles fehlerfrei.

June 14, 2019 at 3:57 pm #4022913

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich verstehe. Legen Sie bitte eine Sichrungskopie der Website un der Datenbank an.

Gehen Sie dann auf WPML -> Support -> Fehlerbehebung und führen Sie die vorhanden Optionen zur Bereinigung der Datenbank durch. Ich hoffe das wird das Problem bereinigen können. Probieren Sie dabei auch gerne alle Optionen zur Bereinigung auszuführen.

Es ist seltsam, dass auch Ihrer Website kein debug.log erstellt wurde. Ich habe das eben nochmals auf Ihrer Website getestet und es werden keine Fehler angezeigt.

Haben Sie bemerkt wann genau das Problem auftritt? etwa direkt nach einem Bestellvorgang?

Sollte die automatische Fehlerbehebung das Problem nicht lösen können wir anbieten Ihre Website auf unseren Testserver zu migrieren, um die Ursache des Problems zu untersuchen und an einer Lösung zu arbeiten.

Mit freundlichen Grüßen
Andreas

June 14, 2019 at 5:04 pm #4023117

Daniela

Hallo,
der Fehler besteht weiter. Ich hatte diese Fehlerbehungsseite auch schon ein paar Mal ausprobiert, aber gerade nochmal. Ändert nichts.
Der Fehler passiert jedesmal, wenn ein Kunde auf der englischen Seite das Produkt bestellt. Direkt nach der Bestellung sind die Varianten beim deutschen Originalprodukt weg. Das ist auch nicht nur bei diesem einen Produkt der Fall. Hier der gleiche mysteriöse Fehler, nur um mal ein weiteres Produkt zu zeigen: hidden link
Auch habe ich schon versucht, das Produkt neu zu erstellen, aber der Fehler taucht dann auch bei dem neu erstellten Produkt wieder auf. Einzige Lösung bleibt die Version 4.3.7. Da gibt es diesen kaum erklärbaren Fehler nicht.
Weder WP debug noch das servereigene Protokoll zeigen irgendwelche Fehler, bis auf die oben genannte php Warnung in_array() expects parameter 2 to be array, null given in /var/www/ador/apps/test/wp-content/plugins/woocommerce-multilingual/compatibility/class-wcml-variation-swatches-and-photos.php on line 57
Aber der Fehler ist ja auch da, wenn das Plugin variation and swatches gelöscht ist 🙁
Gerne können Sie meine Webseite auf Ihren Testserver migrieren. Sie haben auch immer noch Zugang zu der Testseite und ftp. Ich hatte lediglich von http auf https umgestellt.

June 14, 2019 at 8:28 pm
June 14, 2019 at 8:30 pm #4024003

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Nachricht.

Ich habe Ihnen soeben eine private Nachricht auf diesem Ticket hinterlassen, welche Anweisungen zur Migration Ihrer Website auf unseren Testserver beinhaltet.

Hinterlassen Sie mir bitte eine kurze Nachricht, sobald die Migration abgeschlossen wurde.

Mit freundlichen Grüßen
Andreas

June 15, 2019 at 8:29 am #4025849

Daniela

Guten Morgen,
die Migration ist abgeschlossen. Ich hoffe, erfolgreich, zumindest bekam ich keine Fehlermeldung.
Vielen Dank für Ihre Hilfe! Ich bin wirklich sehr gespannt, ob der Fehler gefunden werden kann.
Ich habe den für diesen Post angelegten Testshop nun gelöscht. Sollten Sie noch weitere Zugänge oder ähnliches benötigen, geben Sie mir bitte Bescheid.
Vielen Dank für die Unterstützung.

June 18, 2019 at 12:20 am #4039031

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich wollte Sie wissen lassen, dass ich einige Zeit heute damit verbracht habe, Ihre Seite zu untersuchen.

In der Tat verschwinden die Produktvarianten für das Produkt in Originalsprache, sobald das übersetzte Produkt gekauft wird. Aktualisiert man danach das Originalprodukt sind die Produktvarianten wieder verfügbar.

Das Problem besteht auf der migrierten Website weiterhin. Untersuchungen haben ergeben, dass sich das problem auf der migrierten Website löst, sobald das Plugin Germanized for WooCommerce 2.3.0 deaktiviert wird.

Ich habe versucht das Problem auf der Test-Site nachzustellen, allerdings kommt es hier nicht zu einem Fehler.

Ich habe dies so an unseren L2 Support weitergeleitet und warte noch auf eine weitere Rückmeldung. Mit hoher Wahrscheinlichkeit werde ich die Angelgenheit anschließend an unsere Programmierer weiterleiten, sollte der L2 Support keine Lösung anbieten können.

Ich werde mich morgen wieder bei Ihnen melden.

Mit freundlichen Grüßen
Andreas