This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 30, 2019 at 9:09 am

chrisV-26

I used WMPL to translate my woocommerce store from Greek (main language) to English.

After I translated my products I noticed that some of them don't have a price, options or an "add to cart" button. I tried the steps described here: https://wpml.org/forums/topic/product-variations-not-showing-even-after-trying-suggested-solutions/ to no avail. Furthermore, I noticed that they list as 'simple products' in the backend when they should be variants (almost all my products are variants).

Example Product
Greek: hidden link
English: hidden link

How can I fix this?

P.S. I have currently changed the main language to English, you can switch from the main menu.
P.S.2. The website is still on beta, no traffic whatsoever.

Thank you.

July 30, 2019 at 4:48 pm #4309777

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes, specially WPML plugins, to their latest version. Outdated functionalities can cause conflicts in the code.
- Flush any cache memory that might exists.
- Click on the 'Product categories' link that appears in the admin message and sync all product categories.
- Go to WPML -> Support -> Troubleshooting link -> Apply the steps pointed out in the attached image.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Select all options and click on the 'Apply' button.

Could you tell me if the issue disappeared after the steps above?

Kind regards,
Carlos

August 1, 2019 at 8:54 am #4319989

chrisV-26

Hi,
We followed all the steps you provided us.
However the issue persists.
What should we do next?

August 1, 2019 at 11:29 am #4321117

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

Could you tell me if the issue persists with newly created products too or only previously created products?

Regards,
Carlos

August 1, 2019 at 12:01 pm #4321349

chrisV-26

It does it on new products also. My process is:
- Create a variable product in Greek
- While editing the Greek product change language to English
- Change title/description and save

The English version is a "simple product" instead of "variable". The attributes show up fine.

August 1, 2019 at 6:16 pm #4324623

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm not quite sure I understand this part: "While editing the Greek product change language to English"

How do you exactly switch the language to English? Please attach a screenshot so I can have better understanding.

Regards,
Carlos

August 2, 2019 at 9:38 am #4328575

chrisV-26

I attached the image.

August 2, 2019 at 4:51 pm #4331649

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for attaching the image to your previous message.

According to the image the products are being translated in the wrong way. To translate a product correctly you need to follow the steps described in this link: https://wpml.org/documentation/related-projects/woocommerce-multilingual/#products

Please let me know if you need further help.
Regards,
Carlos