This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Variations are not displayed when the Display untranslated products option is enabled Solution: This is a known issue. To solve it update WooCommerce Multilingual to the latest version.

This topic contains 7 replies, has 2 voices.

Last updated by dmitrijsH 1 year, 5 months ago.

Assigned support staff: Vincenzo.

Author Posts
January 8, 2018 at 4:44 pm #1476735

dmitrijsH

I am trying to:
Display untranslated products using the new feature available in WPML 3.9.
Link to a page where the issue can be seen:
hidden link
I expected to see:
Opportunity to select variations using the selector above the 'Add to cart' button.
Instead, I got:
Blank lines for every options both in default language (LV) and the second language (RU).

Note! Memory limit is still 40M, we will change it asap. Do not know whether this may affect my problem.

January 9, 2018 at 10:46 am #1477646

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I am working to try to reproduce this issue on my local install.

1. In the meantime, can you please paste your WPML Debug information in the Debug information field?
- http://wpml.org/faq/provide-debug-information-faster-support/

2. Can you please tell me if you enabled the "Translatable - use translation if available or fallback to default language" option for the Variations (product_variation) too?

Thank you

January 9, 2018 at 11:14 am #1477727

dmitrijsH

Hello,

I have added the debug info.

Yes, the variations are enabled. And now we also have enough memory for PHP.

January 9, 2018 at 12:47 pm #1477891

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I was not able to reproduce the issue on my test install.

To further debug the problem I’d like to replicate your site locally.

I would need a site snapshot if possible.
We usually recommend the free Plugin “Duplicator” for this purpose.

If you already know how Duplicator works
(https://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the archive file you downloaded.

★ Duplicator Instructions
hidden link
https://wpml.org/faq/provide-supporters-copy-site/

If the file is too large (more than 200M), please use the Duplicator file filters to remove the cache, the wp-uploads directory, the media and the archive files.

Send me the archive file (you probably want to use Google Drive, DropBox, or similar services, as the snapshot file will be quite big)

Your next reply will be private, which means that only you and I will be able to see it and have access to it. You can paste the link to the file there. You can also share the credentials to your website. I will then download the file from the admin panel.
Once the problem is resolved I will delete the local site.

Please let me know if you need help creating the Duplicator package.

Thank you

January 9, 2018 at 4:09 pm #1478271

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I talked with our developers and it seems like this is a known issue.

Our developers have already fixed it and the solution will be available with the next version of WooCommerce Multilingual.

I will update this ticket as soon as the new version will be released.

Thanks for your patience

January 10, 2018 at 10:10 pm #1480637

dmitrijsH

Hello,

Thank you.

January 16, 2018 at 9:16 am #1485667

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I would like to inform you that we just released WooCommerce Multilingual 2.8.0
- https://wordpress.org/plugins/woocommerce-multilingual/#developers

❌ Before proceeding please make a full website backup! ❌

Can you please update WooCommerce Multilingual and let me know if this fixed the issue?

Thank you

January 16, 2018 at 9:34 pm #1486676

dmitrijsH

Hello,

Thank you. It seems that now it shows the variations correctly.

However, when this option is enabled untranslated products do no appear at the Storefront homepage. They are only visible in specific categories. Link to see: ru.ortoteka.lv