Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The products created before wpml installation don't show the product variations.

Solution: In this particular case deactivating and reactivating CMS Multilingual solved the issue.

Further, the WCML troubleshoot options at WooCommerce -> WooCommerce Multilingual -> Support -> Troubleshooting should show options in order to synchronize products.

This topic contains 2 replies, has 2 voices.

Last updated by rosemaryS 5 months ago.

Assigned support staff: Andreas W..

Author Posts
September 24, 2019 at 3:54 am #4627821


The most products created before wpml installation don't show variations and I can't make any change (expand option doesnt work properly), I realized today because I want to create an new order with size from my admin account but I can't find, only I see the option in my recently products.

This issue give another problem with paypal payments, because say my site has problems.


Rosemary Saavedra

September 24, 2019 at 6:26 pm #4633561

Andreas W.

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)


Thank you for contacting the WPML Support Forum.

If the product variations do not show up, please first try the WCML troubleshoot options at WooCommerce -> WooCommerce MUltilinguial -> Support -> Troubleshooting.

If this will not solve the issue it might be that there is a compatibility issue between WooCommcer Multilingual and another plugin.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:

Let me know about the outcome.

Kind regards

September 24, 2019 at 7:11 pm #4633789


My issue is resolved now. Thank you!

I followed the steps that Andre recomended me, The first doesn't work.

I desactived plugin one by one and I find that WPML Multilingual CMS cause the problem, when actived the plugin again the issue was resolved. Thanks.