This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 31, 2019 at 8:33 am

francoisD-4

Hi,

I try to edit my product but some variations are un-editable because they are invisible, but they exists.

I already check solutions as :
• hit all buttons in woocommerce multilingual troubleshooting page
• hi all buttons (almost) in wpml cms multilingual troubleshooting page
• Deactivate WPML, the variations reappeared, re-save the product. Reactivate WPML, and the variations are invisible again.

I already checked the forum solutions... As it is a problem since 2015, even earlier, I hope you have a solution for this.

I grant you access to the dev environment and I have a backup. You can break everything if you want.

Thank you

July 31, 2019 at 1:46 pm #4314869

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I applied some troubleshooting options in the site. If the issue persists I kindly ask you to provide a specific product where the issue is present.

Kind regards,
Carlos

July 31, 2019 at 2:02 pm #4315059

francoisD-4

Hi thanks for your reply.

The problem remains the same.

I should have told you on what product you can see the problem (there are many product where the problem exists).

Here's one :
Polar Mint > hidden link

As I said, I already applied a lot of troublshooting options.

Thanks

July 31, 2019 at 2:21 pm #4315235

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your message.

I suspect there might be a conflict between WPML and a third party functionality. For this reason I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

July 31, 2019 at 6:39 pm #4317281

francoisD-4

Are you sure this is the solution ?
Because when I deacticate WPML, the problem is gone, and is back again when I reactivate it...
Ok I will do what you say but I'm very skeptical...

August 1, 2019 at 8:11 am #4319543

francoisD-4

Hi Carlos.

I have done what you asked and I still have the problem.
As you can see, the active theme is twenty19, the only active plugins are Woocommerce and Wpml, and the variations are still missing.

August 1, 2019 at 11:21 am #4321047

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Then the cause of this issue is most probable in the database.
I will consult our specialists about this issue and I will get back to you as soon as possible.

Thank you very much for your patience.
Regards,
Carlos

August 1, 2019 at 2:04 pm #4322519

francoisD-4

Hi,

Thanks for you answer. I'll strongly wait for an answer asap as the production website has the same issues than the dev.

Do I have to modify something on the DEV website for the specialists ?

Thank you

August 1, 2019 at 6:28 pm #4324687

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I will let you know if its necessary to make some modifications on the DEV site. I will get back to you as soon as I get an answer.

Regards,
Carlos

August 2, 2019 at 11:44 am #4329701

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I have escalated this ticket to our 2nd tier of support. Our 2nd tier specialists will take a deeper look at the issue and will try to find a solution.

I will keep you updated about the evolution of this ticket.

Best regards,
Carlos

August 5, 2019 at 3:34 pm #4341637

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

If you re-create the variations the issue will be solved. The cause of the issue is that the variations are have different languages in the database which is incorrect and as a consequence don't see all of them while editing the product.

Regards,
Carlos

August 6, 2019 at 9:47 am #4345857

francoisD-4

Hi Carlos,

What causes this ? Because a few weeks ago, all was fine. The website is live since october 18, and everything was fine untill July 2019.

I have so many product and it will take a lot of time to recreate all variations. And it doesn't feel like it's solution to recreate all.

Can you try your solution on my dev website and confirm it's viable ?

Thank you

August 6, 2019 at 9:59 am #4346051

francoisD-4

Let me show you this.
In woocommerce multilingual, my attributes terms have different original languages, even if I have created them in English language first.
In product attributes, they are detected as English as original language.

August 6, 2019 at 12:35 pm #4347407

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

You can change the original language of the attribute terms in WPML -> String Translation by following this steps: https://wpml.org/documentation/getting-started-guide/string-translation/#original-language-of-strings

Regards,
Carlos

August 6, 2019 at 9:38 pm #4350529

francoisD-4

Hi,

This is not the answer I was looking for. I show you this because wpml changed the original language on its own, and maybe that is a part of the problem.

However I tried your solution to recreate variations, and it worked.

This is what I did :
• Recreate attribute in EN.
• Translate them in FR
• Recreate variations on the POLAR MINT product. Now I have 5 variations, but only 3 are shown (image 1)
• I update the product translation FR. And now I have 5 variations on POLAR MINT FR and 3 are shown.

I'm kind not satisfied by this solution because there are still "ghost variations", and most importantly, I have to recreate all variations by hand wich means 60 products × 3 variations × 2 languages what will take a lot of time.

Please tell me there is a better solution, or I'm doing somethin wrong...