This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by jeannetteK-2 1 month, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
March 17, 2019 at 3:49 pm #3363859

jeannetteK-2

My webshop is in English and Dutch (first language).
Everything works well except for 1 product: hidden link
On the Dutch page the stock is right. On the English page stock is 2 for all variations. If I remove the color 0, stock for the English page is right, but then it does not show all variations.

What could the problem be?

Kind regards,

Jeannette

March 18, 2019 at 12:48 pm #3369379

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jeannette,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This may be a stock/variation sync issue. Please try the following steps after a full site backup and make sure the issue is existing or not.

a) Visit WooCommerce>>WooCommerce Multilingual>>Status
b) Click on *Troubleshooting* link(blue on the bottom of the page)
c) Choose *Sync products variations* and *Sync product stock quantity and status* option
d) Click on *Start* button

Please check the attached image for more details and let me know your feedback.

--
Thanks!

Bigul

March 18, 2019 at 2:57 pm #3370541

jeannetteK-2

Hi Bigul,

I have done this, but it did not solve the problem.

Are there any other things I could do?

Kind regards, Jeannette

March 18, 2019 at 5:39 pm #3371987

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jeannette,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

March 20, 2019 at 6:12 pm #3392299

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jeannette,

Thank you for the login information. Have you made any changes in the *wpml-config.xml* file of WooCommerce Multilingual plugin? Because WooCommerce>>WooCommerce Multilingual>>Status page is showing a notification.

The *Coverderm Classic* product is showing the correct result in the edit page for me. Please check the attached images.

Please update the product in the default language(just resave) to refresh the translation settings and then update the translation. After that check, the issue is existing or not.

--
Thanks!

Bigul

March 21, 2019 at 10:24 am #3398035

jeannetteK-2

Hi Bigul,

As far as I know I have nod made any changes in the *wpml-config.xml* file of WooCommerce Multilingual plugin. Maybe a plugin I use did?

I saved my product in Dutch and English, but nothing happens.

Kind regards,

Jeannette

March 22, 2019 at 6:40 am #3437763

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jeannette,

Thank you for the feedback. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link in the middle of the page)
3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

March 25, 2019 at 3:26 pm #3455431

jeannetteK-2

Hi Bigul,

Thank you for troubleshooting steps. Due to personal reasons it will take me some more days before I can do this. I hope I can work on this issue this Thursday, otherwise it will become next week Wednesday or Thursday.

I will let you know if it works.

Kind regards, Jeannette

March 26, 2019 at 6:15 am #3459313

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jeannette,

Thank you for the updates. Please take your own time. We will wait for your feedback.

--
Thanks!

Bigul

April 11, 2019 at 10:55 am #3586415

jeannetteK-2

Hi Bigul,

Finally I had time to follow your steps, but it did not change anything.

Do you have any other options?

Jeannette

April 11, 2019 at 5:52 pm #3591727

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jeannette,

Thank you for the feedback. Just to make sure, it is only happening with a single Product, am I right?

Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

April 15, 2019 at 11:08 am #3612823

jeannetteK-2

Hi Bigul,

I have made a backup with Duplicator.
How do I send it to you?

Jeannette

April 16, 2019 at 7:10 am #3618647

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jeannette,

Thank you for your permission. I have downloaded the Duplicator copy now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

April 17, 2019 at 8:53 am #3628829

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jeannette,

For your kind updates, the issue is existing after the initial debugging steps. Therefore I have shared the details with our second tier team for the expert opinion and waiting for the feedback now.

We will get back to you as soon as possible. Please wait.

Just to make sure, now the issue is only happening with a single Product, am I right?

--
Thanks!

Bigul

April 20, 2019 at 8:55 am #3649917

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jeannette,

For your kind information, the bug is existing after our primary debugging procedures. Therefore I am escalating the ticket our second tier team for further debugging. We will get back to you soon. Please wait.

--
Thanks!

Bigul