This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by erasmoL 1 month, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
August 20, 2019 at 11:28 am

erasmoL

I am trying to:
Translate a page with a VC portfolio but it is showing as empty on translated pages

Link to a page where the issue can be seen:
hidden link
(this is the working page in the default language, Italian)
hidden link

I expected to see:
The portfolio "posts" displaying

Instead, I got:
Empty portfolio

August 20, 2019 at 1:00 pm #4423813

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please check if any of the confirmed solutions in the ticket links below helps you solve this issue on your site, too?

- https://wpml.org/forums/topic/salient-theme-copy-content-in-a-portfolio-item-not-working/
- https://wpml.org/forums/topic/wpml-translation-visual-composer-issue-with-theme-salient/
- https://wpml.org/forums/topic/portfolio-items-does-not-show-up-on-translated-pages/

Please let me know how that goes.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 20, 2019 at 1:39 pm #4423953

erasmoL

Hello Mihai, thanks so much for the quick reply! One question regarding this answer
https://wpml.org/forums/topic/wpml-translation-visual-composer-issue-with-theme-salient/
I cannot see "translation management" in the plugin menu. Is it because I only have the base version of the plugin?

August 20, 2019 at 2:05 pm #4424293

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Yes, you are right!

I did not realize that you are using the "Multilingual Blog" membership type.

Here you can find the features comparison between all the membership types:
https://wpml.org/purchase/

To translate content that was built with a content builder (like visual composer/wp bakery), you would need to be at least on the middle membership type (you would pay just the difference between what you paid already and the next membership type) and that's when you will have access to download WPML String Translation and WPML Translation Management.

I hope that this clears things up a bit more and that you will find it helpful 🙂

Kind regards,
Mihai Apetrei

August 20, 2019 at 5:33 pm #4425737

erasmoL

Hello Mihai,

I upgraded WPML with the upper plan, I tried to follow the steps in the answers you suggested me but I still cannot see the content of the portfolio element.
Can you help me :)?
Thanks in advance!

August 21, 2019 at 6:31 am #4428225

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Can you please try this:

1. Go to WPML -> Settings -> "Custom XML Configuration" tab

2. Paste the following code there:

hidden link

3. Go to the page in the default language, make some small change to the content and click Update.

Now when you edit the translated page, you should see all the fields.

Please let me know if that solved the issue.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 21, 2019 at 9:43 am #4429653

erasmoL

Hello Mihai!

Thanks for your reply! I tried the steps yousuggested me but I still cannot see the content of the portfolio. I even tried to delete the page and create another one but still nothing..

Thanks in advance for the further help

August 21, 2019 at 2:55 pm #4432449

erasmoL

Hello Mihai! Sorry to bother you but it's quite urgent...can I have some help for this?
Thanks in advance

August 21, 2019 at 9:42 pm #4435157

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

After a deeper research, it seems that what we are targeting is not a Visual Composer / WP Bakery shortcode, but instead, we are targeting this exact Nectar shortcode ([nectar_portfolio layout="3" category="sport" project_style="5" item_spacing="default" load_in_animation="none"]) that was created by the developers of the Salient theme (the base theme that your current theme was created from).

It seems that you would need to go here (hidden link) and translate the portfolio items as it is mentioned here:
https://wpml.org/documentation/theme-compatibility/create-multilingual-wordpress-websites-using-the-salient-theme-and-wpml/#translating-portfolio-pages-and-categories

Can you please try that and let me know how that goes?

This should solve the issue.

I will be waiting for your response to see if this worked.

Kind regards,
Mihai

August 23, 2019 at 8:10 am #4444981

erasmoL

My issue is resolved now. Thank you!