This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Andrés 4 months, 1 week ago.

Assigned support staff: Andrés.

Author Posts
June 11, 2019 at 7:06 am #3992303

gholamA

Hello,

I install the wpml plugins with composer and since the version you released initially had a version naming issue with 1.3 (it is stored as 1.3.0 and does a redirect from 1.3 to 1.3.0).
My build pipeline fails constantly, since composer follows from 1.3 to 1.3.0 and has then a hickup using it, since it should be 1.3.

eg:
"package": {
"name": "wpml/acfml",
"version": "1.3",

gets stored as "1.3.0" in composer.lock and then on the CI it fails because this version does not exist.
Would be great if you could just upload the version 1.3 additionally and remove that redirect.

Thanks, Markus

June 11, 2019 at 7:20 am #3992727

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Markus,

Welcome to WPML support forum.

Thank you for bringing this situation to us. At the moment I'm consulting with our 2nd tier in order to provide you an answer.

Best regards,
Andrés

June 11, 2019 at 8:45 am #3993363

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

I just received a feedback. Do you think it would be possible to specify in your composer.json file that version of acfml must be “>1.2”? It will be resolved in .lock file to “>1.2.0” and maybe it will find that next version is 1.3.

On the other hand, would it be helpful if our next release would be 1.4.0 instead of 1.4?

Regards

June 11, 2019 at 9:36 am #3993655

gholamA

Actually I never had an issue with the versions before. Could it be the case that you released 1.3.0 initially and renamed it to 1.3 afterwards (at least this is what I experienced). I guess it would be ok if it is 1.4 next time too, since only 1.3. version is creating issues.
Of course it would be great to see proper semantic versioning.

Since am not able to deploy since two weeks now (and didn't realize), when 1.4.0 will be out, or a 1.3.1 patch release?

Thanks, Markus

June 11, 2019 at 10:06 am #3993963

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thank you very much for sharing your thoughts, Markus, I'll pass them to our 2nd tier support. On the other hand, we don't have a new release date establish so far, but we can let you know as soon it is ready.

Regards,
Andrés