This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 10.17 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by Lauren 3 weeks, 2 days ago.

Assigned support staff: Lauren.

Author Posts
September 20, 2019 at 3:55 pm #4613421

Przemysław Poyan-Pogorzelski

Tell us what you are trying to do?

Hello, with wpml plugin on I have very slow admin backend, When I try to update product page it takes about 12s to save

- without wpml ~3,8s
- string translations off ~5-6s
- wpml translation managment off ~5s

All plugins are up to date, php 7.3, memory limit 3000mb, cloud server with litecache speed (but same times with duplicator and local copy on i7 7700k, 16gb ram and ssd)

String recording all off

Any advise?

September 20, 2019 at 4:48 pm #4613669

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyNineteen. With these settings, does the performance issue change?

September 20, 2019 at 5:28 pm #4613853

Przemysław Poyan-Pogorzelski

all plugins were disabled only wpml are active, everything is up 2 date

September 20, 2019 at 8:26 pm #4614349

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 21, 2019 at 7:53 am #4615525

Przemysław Poyan-Pogorzelski

maybe better I will send you a dupicator installer?

September 23, 2019 at 7:17 pm #4626233

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

September 24, 2019 at 7:43 pm #4633945

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending the duplicator snapshot. I was able to reproduce this locally, so I will continue troubleshooting there. I will update here just as soon as I have more information.

September 25, 2019 at 2:03 pm #4639649

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

On my test copy of your site, I set the site to minimal settings (only WooCommerce and WPML plugins with a default theme). I then deactivated and deleted the current stable WPML plugins and installed the beta versions of WPML core, String Translation, Translation Management and WooCommerce Multilingual and am seeing much improved performance. Is this something you can set up a staging site on your server to test? If you have the same results, begin activating your theme and the rest of the plugins one at a time and then we will see if there is any in particular causing a conflict. I did find that the WooCommerce Cache Handler plugin added an additional 10 seconds when updating a product in my test site after following the above steps.

If you do not have a test site, be sure to have a full backup of your site before testing this on the live site.

You can download the beta versions at http://www.wpml.org/account/downloads and select "beta" from the drop down. Please let me know the results.

September 25, 2019 at 4:38 pm #4641255

Przemysław Poyan-Pogorzelski

Hi, I've copy of the page localy, uninstalled wpml, and installed beta and there is no change. I'm not using this woocommerce cache handler, just forgot deleted before page duplicate

September 25, 2019 at 5:19 pm #4641463

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please see my previous private reply and let me know once the migration has been completed. Thanks!

September 25, 2019 at 7:19 pm #4641839

Przemysław Poyan-Pogorzelski

its done 🙂

September 26, 2019 at 2:21 pm #4647599

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much. In this test site, I followed these steps and the save time for a translated product is less than 2 seconds (I tested "Detachable sleeves in Black Coffee").

1. Disable all plugins other than WooCommerce
2. Install WPML Beta versions of Core, String Translation, Translation Management and WooCommerce Multilingual
3. Go to WooCommerce -> WooCommerce Multilingual -> Support and click the troubleshooting link at the bottom of the page. Run through all the steps here.
4. Go to WPML -> Support and click the Troubleshooting steps. Run through the steps in the Clean Up section, and for the first option, run for both products and variations.

After this, I edit a product and save and it takes less than 4 seconds. I edit a translation and save and it takes less than 2 seconds.

Please confirm you are experiencing the same results on the new staging site I set up. If so, you can then begin activating theme and plugins one at a time until we see the site slow down.

September 26, 2019 at 3:07 pm #4648199

Przemysław Poyan-Pogorzelski

I see, it's much faster than before, we can check with plugins activated

September 26, 2019 at 4:29 pm #4648889

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Great, please test on this staging site so that we can both see the results. I suggest activating just a few at a time, so that we can identify where the problem is coming from. If all are activated and the issue does not come back, then I think we can assume the beta plugins and the cleanup steps resolve the issue.

Please keep me posted of your tests.

The topic ‘[Closed] Very slow admin edit/update product page’ is closed to new replies.