This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Bigul 1 year ago.

Assigned support staff: Bigul.

Author Posts
September 23, 2018 at 2:42 pm #2758764

Oscar

Hello,

this week my WordPress backend is very very slow. Sometimes even got 503 errors when working on the website.

I was adding some Woocommerce product filters and make some translations with the taxonomy translation option but everything is so slow. I'm working for hours to find problems and to add those filters but after 3 hours I'm stucked on 5% on the work I need to do.

I updated all the plugins to the latest version but without luck. I added extra memory to have better performance, no luck.

Also saving products can take ages. Making translations with the translation manager and hit the save button can take more then 2 minutes before it's saved.

Whatever I do with WPML, everything is slow.

Hope you can help with this problem. Many thanks already.

Regards,

Oscar

September 25, 2018 at 7:05 am #2762701

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Oscar,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please let me know the result of the following for tracking the issue.

a) Please activate Query Monitor plugin and check is there any slow query related to WPML

b) Please deactivate WPML String Translation for a moment and check is there any difference in the site performance

Are you using a shared hosting or VPS for hosting the site?

--
Thanks!

Bigul

September 30, 2018 at 1:14 pm #2776504

Oscar

Hello Bigul,

thanks for your reply.

1. Did activate the plugin, see attachment, this is slow as Query monitor says.

2. De-activated string translations, Website is super fast again, as it should be.

Hope you have a fix.

Best regards,

Oscar

October 1, 2018 at 12:07 pm #2778043

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Oscar,

Thank you for the feedback. Please let me know the following for tracking the issue.

a) In which all pages/sections you are getting the slow queries? Normally how much time it is taking for loading(as per Query Monitor result)

b) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

c) Are you using a shared hosting or VPS space for hosting the site

d) Is it possible to consider a staging site(clone copy of the live site) on the same server for a detailed performance debugging? So we can do the testing on the same environment without affecting the live site.

--
Thanks!

Bigul

October 2, 2018 at 11:09 am #2781200

Oscar

Hi Bigul,

thanks for your reply.

This was never a problem before, started a couple of weeks ago.

When I search support forum I see more people having this problem.

When I de-activate the plugin everything is fast again. Query monitor is saying string translations is slow.

Would like to test but testing costs me a lot of time.

Best regards,

Oscar

October 3, 2018 at 8:31 am #2783925

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Oscar,

Thank you for the feedback. Have you made any changes in the site or site settings or server configuration in the last two weeks?

Please share me the following details for tracking the issue.

a) Are you using a shared hosting or VPS space for hosting the site

b) Is it possible to consider a staging site(clone copy of the live site) on the same server for a detailed performance debugging? So we can do the testing on the same environment without affecting the live site.

c) Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

The topic ‘[Closed] Very slow backend, can't work with this slow website’ is closed to new replies.