Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Some product custom fields are not available for translation.

Solution: Go toWPML -> Translation Management -> Multilingual content setup -> Custom fields -> and set the fields to translate.

If you can't find them try clicking on "Show system fields"

This topic contains 10 replies, has 3 voices.

Last updated by carolineC-4 3 years, 3 months ago.

Assigned support staff: Otto.

Author Posts
September 4, 2016 at 9:47 am #1059056

Stavros Chalaris

I follow the instructions that u have
https://wpml.org/forums/topic/translations-queue-instead-of-woocommerce-multilingual/

and the fields of video, related products and pdf is not transferred from main language, I have to edit and save it again to second language too.

September 5, 2016 at 3:05 pm #1061184

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

Do you want those fields to be copied from the original instead of translating them?

Please try the following:
-Go to WPML > Translation Management > Multilingual content setup > Custom field translation
-Search for those fields and set the status to "Copy from original to translation"

If this is not what you are asking, can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of “upload an image” below the comment area.

Kind Regards,

Otto

September 5, 2016 at 9:16 pm #1061812

Stavros Chalaris

I found the video field but the related and pdf, I didn't found it why?

September 5, 2016 at 9:29 pm #1061820

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

It depends on how they are set by the theme or plugin.

Please try the following:
1. Go under “WPML -> Theme and plugins localization”
2. Make sure that “Translate the theme and plugins using WPML's String Translation” is active
3. Scroll down to “Strings in the theme” and click on “Scan the theme for strings”
4. Scroll down to “Strings in the plugins”, select the plugin you want to scan and click on “Scan the selected plugins for strings”

And check if the fields appear.

Can you please let me know from where are those fields coming from? Theme, plugin, which one?

Kind Regards,

Otto

September 6, 2016 at 9:34 pm #1064087

Stavros Chalaris

Thank you for the tips. They are plugins.
Do you want to give access in wp-admin to check them too?

September 6, 2016 at 9:43 pm #1064091

Stavros Chalaris

Also the "Custom field translation" has no enable any plugin after the last update that you told me to do.

September 7, 2016 at 11:49 am #1065297

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Kind Regards,

Otto

September 7, 2016 at 6:13 pm #1066357

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for granting me access to your site.

I went to WPML > Translation Management > Multilingual content setup > Custom fields > and clicked on "Show system fields"

After that there are two fields that I think should do the trick:
_related_ids
_pdf_link

Please let me know if this helped.

For the other issue, may I kindly ask you please to open a new ticket for your new question? This way we will be able to help you better and also help other users with similar problems find solutions when searching the forum.

When opening a new ticket you will be able to assign it to me directly, if you prefer.

Thank you!

Kind Regards,

Otto

September 9, 2016 at 7:27 am #1070049

Stavros Chalaris

Thank you everything works fine.

September 9, 2016 at 10:38 am #1070736

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

I'm glad to hear that 🙂

Kind Regards,

Otto

April 25, 2019 at 3:42 am #3678701

carolineC-4

-