Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by sofiaT 5 years ago.

Assigned support staff: Tia.

Author Posts
November 18, 2015 at 9:19 am #748704


I am trying to: Present wc products into the english version of the website using visual composer.

URL of (my) website where problem appears: hidden link

I expected to see: English version of produts.

Instead, I got: Greek Version of produts.

November 18, 2015 at 6:27 pm #749486


Hello. Thank you for contacting WPML Support. I am happy to help you with this.

- Does an English translation exist for the page you are displaying? (This is the homepage, correct?)

- If you go to WPML > WooCommerce Multilingual do you get an error that says "WooCommerce store pages doesn't exist"? If so, please set up the store pages:

- What is the default language of the website?

Can you tell me if you already checked the following? This will help narrow down the issue:

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

A. Update all WPML plugins & WordPress core.

B. Minimal Set Up ( 1. All plugins except WPML disabled 2. and then Temporarily changing the theme to a default WordPress such as TwentyFifteen 3. then finally enable all plugins and disable all WPML related ).

C. If the issue is gone after Minimal Set Up steps above, activate each plugin one by one to find out which plugin is causing the issue.

Does the issue still persist when you do each step above?

Thank you in advance for the information above. This will help me come to a faster resolution.

November 20, 2015 at 5:36 pm #751523


It seems like Revolution Slider plugin caused the issue. I had a slider that it was not set to be working with wpml. As soon as i turn that feauture on i had no problem with the issue i was facing.